Go Back   TeamTalk > Search Forums

Showing results 1 to 7 of 7
Search took 0.02 seconds.
Search: Posts Made By: JJP
Forum: Electrical 10-05-2009, 03:29 PM
Replies: 12
Views: 843
Posted By JJP
Jim, a many Thanks for your help! I called and...

Jim, a many Thanks for your help! I called and talked to Brian at MasterCraft of Charlotte, and that small red wire on my model of boat does not get hooked to anything. So now I will take...
Forum: Electrical 10-05-2009, 11:34 AM
Replies: 12
Views: 843
Posted By JJP
Jim, sounds good. I'll get those pic's...

Jim, sounds good. I'll get those pic's hopefully tonight if not raining still.

Thanks!
Forum: Electrical 10-05-2009, 09:31 AM
Replies: 12
Views: 843
Posted By JJP
Jim, this whole thing with the wires started...

Jim, this whole thing with the wires started when my alternator broke one of the mounting bolts. At that time I took the alternator in to have checked and make sure no problems and the electrical...
Forum: Electrical 10-04-2009, 07:26 PM
Replies: 12
Views: 843
Posted By JJP
Jim, yes the wires you stated are hooked up just...

Jim, yes the wires you stated are hooked up just like you said. It's this darn red wire on the S terminal that I am not sure where it should go, which I believe should be hooked into the ingnition...
Forum: Electrical 10-04-2009, 05:47 PM
Replies: 12
Views: 843
Posted By JJP
Alternator question...

On our 2001 X-Star with LTR 330, I have noticed that on the alternator there is a red wire on the S terminal going to nothing. Any one know where this is suppose to be hooked up to? I do believe...
Forum: General Discussion 10-02-2009, 01:52 PM
Replies: 17
Views: 1,746
Posted By JJP
2001 X-Star as of Tuesday 768 hrs.

2001 X-Star as of Tuesday 768 hrs.
Forum: General Discussion 10-02-2009, 01:50 PM
Replies: 17
Views: 1,746
Posted By JJP
2001 X-Star and have 768hrs as of Tuesday.

2001 X-Star and have 768hrs as of Tuesday.
Showing results 1 to 7 of 7

 

All times are GMT -4. The time now is 07:41 AM.