Go Back   TeamTalk > Search Forums

Showing results 1 to 25 of 37
Search took 0.01 seconds.
Search: Posts Made By: JLMax16
Forum: General Discussion 08-14-2013, 01:23 PM
Replies: 27
Views: 2,562
Posted By JLMax16
My perko failed also. Thankfully I have an auto...

My perko failed also. Thankfully I have an auto bilge pump that started throwing water out of the boat, we were at a sandbar and never would have noticed, until we went to leave hours later. Here's...
Forum: Engine / Drive Train 05-24-2013, 01:34 AM
Replies: 8
Views: 1,138
Posted By JLMax16
Do you know what the Napa part number is? I'm...

Do you know what the Napa part number is? I'm leaving for Havasu in the morning and when I fired the boat up today, the recirc pump is rattling and the pulley wiggles. I don't want to have to pull it...
Forum: Engine / Drive Train 05-18-2013, 06:17 PM
Replies: 9
Views: 1,074
Posted By JLMax16
Here's what the middle exhaust holes look like....

Here's what the middle exhaust holes look like. They have some wear that looks like it could affect a good seal.
Forum: Engine / Drive Train 05-18-2013, 04:27 PM
Replies: 9
Views: 1,074
Posted By JLMax16
Day two of bolt removal. The exhaust manifold I...

Day two of bolt removal. The exhaust manifold I pictured, isn't the one giving me issues. I'm having to drill out two bolts. It's a nightmare. Anyway, when I put on the new manifolds I was instructed...
Forum: Engine / Drive Train 05-05-2013, 06:42 PM
Replies: 12
Views: 2,324
Posted By JLMax16
And would anyone know the part number for the LTR...

And would anyone know the part number for the LTR 330?
Forum: Engine / Drive Train 05-05-2013, 06:37 PM
Replies: 12
Views: 2,324
Posted By JLMax16
I've read bad things about GLM, have they...

I've read bad things about GLM, have they improved over the past few years? The issues I read were people having to get them machined because they weren't flat.
Forum: Engine / Drive Train 05-01-2013, 08:05 PM
Replies: 12
Views: 2,324
Posted By JLMax16
Speaking of rusty and flaky.... is this bad?...

Speaking of rusty and flaky.... is this bad? Should I replace my exhaust manifold? It's getting hot enough to melt the carpet (you can see the half moon shape in the bottom of the picture).
Forum: Engine / Drive Train 05-01-2013, 06:58 PM
Replies: 9
Views: 1,074
Posted By JLMax16
Awesome. Where would I find some new exhaust...

Awesome. Where would I find some new exhaust manifolds online? I've had the boat for 4 years. Took it in salt water twice. Thoroughly flushed it with salt away and everything. Noy sure what the...
Forum: Engine / Drive Train 04-30-2013, 11:02 AM
Replies: 9
Views: 1,074
Posted By JLMax16
Here's a picture of what I'm talking about.

Here's a picture of what I'm talking about.
Forum: Engine / Drive Train 04-13-2013, 06:53 PM
Replies: 15
Views: 1,692
Posted By JLMax16
I take my grandpa. I never catch anything.

I take my grandpa. I never catch anything.
Forum: Engine / Drive Train 04-13-2013, 02:16 PM
Replies: 9
Views: 1,074
Posted By JLMax16
Going to highjack my own thread a little bit....

Going to highjack my own thread a little bit. I've also been having issues with vapor lock? Cold starting is no problem, I'll run the boat for a while, it will get up to operating temp. When I go to...
Forum: Engine / Drive Train 04-13-2013, 01:38 PM
Replies: 9
Views: 1,074
Posted By JLMax16
Indmar LTR 330 headers cleaning?

I have a 2001 X9 with an Indmar LTR 330HP motor. On the port side of the motor I have noticed some increased rust on the underside of the headers, running down the block. I've also noticed that the...
Forum: Engine / Drive Train 04-13-2013, 01:23 PM
Replies: 15
Views: 1,692
Posted By JLMax16
Just realized I never followed up on this, while...

Just realized I never followed up on this, while searching for another issue. Ended up that the oil pan was leaking because the weld around the threaded part that holds the drain plug, rusted out. I...
Forum: Engine / Drive Train 09-04-2012, 02:55 PM
Replies: 19
Views: 1,565
Posted By JLMax16
That's what mine is doing. I have to put it in...

That's what mine is doing. I have to put it in neutral and at WOT to get it to start, and it throws a lot of smoke which smells rich. I'm going to be pulling out the injectors in the next few days to...
Forum: Engine / Drive Train 08-25-2012, 01:39 PM
Replies: 507
Important: Fuel Pump 101
Views: 89,557
Posted By JLMax16
Tested fuel pressure today. 40psi at the rail...

Tested fuel pressure today. 40psi at the rail before start and while running.

The warm start issue I have is while lying flat in the water.

The other issue I was describing is separate from the...
Forum: Engine / Drive Train 08-25-2012, 01:02 AM
Replies: 507
Important: Fuel Pump 101
Views: 89,557
Posted By JLMax16
After checking codes on my '02 X-9 I found that...

After checking codes on my '02 X-9 I found that the TPS sensor was faulty. After replacing that the boat runs great! BUT I'm still having warm start issues, where I have to be at WOT to start the...
Forum: Engine / Drive Train 08-23-2012, 11:31 PM
Replies: 19
Views: 1,565
Posted By JLMax16
Swat- I never replaced the thermostat, I did...

Swat- I never replaced the thermostat, I did replace the coolant temp sensor. I'm not sure what vehicle I looked up to get it (it was a while back), but I did get the throttle position sensor by...
Forum: Engine / Drive Train 08-22-2012, 02:57 PM
Replies: 19
Views: 1,565
Posted By JLMax16
How do I do that?

How do I do that?
Forum: Engine / Drive Train 08-21-2012, 07:39 PM
Replies: 19
Views: 1,565
Posted By JLMax16
I got stuck in a thunderstorm in Havasu a couple...

I got stuck in a thunderstorm in Havasu a couple times, with 3 ft swells blowing over the bow. But these issues started before that. I'll check it out though, thanks.
Forum: Engine / Drive Train 08-21-2012, 03:53 PM
Replies: 19
Views: 1,565
Posted By JLMax16
Also, I replaced my fuel pump back in '09. Was...

Also, I replaced my fuel pump back in '09. Was this fuel pump model number affected?
Forum: Engine / Drive Train 08-21-2012, 03:44 PM
Replies: 301
Views: 65,873
Posted By JLMax16
I have an '01 X-9 with an LTR 330HP Indmar. I...

I have an '01 X-9 with an LTR 330HP Indmar. I recently replaced my TPS due to rough running issues and throwing codes. But have still not figured out why (when the engine is warm) I have issues...
Forum: Engine / Drive Train 08-21-2012, 03:03 PM
Replies: 19
Views: 1,565
Posted By JLMax16
71-332s

71-332s
Forum: Engine / Drive Train 08-20-2012, 07:34 PM
Replies: 19
Views: 1,565
Posted By JLMax16
nobody?

nobody?
Forum: Engine / Drive Train 08-16-2012, 09:17 PM
Replies: 19
Views: 1,565
Posted By JLMax16
'01 LTR330 warm start issue

In the past year or so I have been having a few intermittent issues that came to a head 2 weeks ago. I was having power issues, bogging with takeoff and (at a cruising speed) an erratic RPM. On top...
Forum: Engine / Drive Train 08-03-2012, 09:27 PM
Replies: 24
Views: 2,418
Posted By JLMax16
What ended up being your issue?

What ended up being your issue?
Showing results 1 to 25 of 37

 

All times are GMT -4. The time now is 01:25 AM.