Go Back   TeamTalk > Search Forums

Showing results 1 to 17 of 17
Search took 0.00 seconds.
Search: Posts Made By: NParkhurst
Forum: General Discussion 05-13-2014, 02:27 PM
Replies: 12
Views: 486
Posted By NParkhurst
Found the J hose at both my Knoxville MC dealer...

Found the J hose at both my Knoxville MC dealer (American Boat Center) and Cleveland Boat Center for $42. Fortunately my J hose was not torn or busted, just came loose. I am going ahead an buying...
Forum: General Discussion 05-08-2014, 03:14 PM
Replies: 12
Views: 486
Posted By NParkhurst
Any recommendations on a parts supplier? In...

Any recommendations on a parts supplier? In addition to J hose, need to replace bilge pumps, and a few gas struts.

Thanks for all the advice, glad to have this identified early in the season.
Forum: General Discussion 05-08-2014, 01:16 PM
Replies: 12
Views: 486
Posted By NParkhurst
Here's a video. Have not changed the impeller...

Here's a video.

Have not changed the impeller yet this season, I always change the oil/filter, impeller, etc at the beginning of the season. I don't like to let a new impeller sit all winter.
Forum: General Discussion 05-08-2014, 10:43 AM
Replies: 12
Views: 486
Posted By NParkhurst
Identified my issue, appears to be water intake...

Identified my issue, appears to be water intake hose problem.

Ran out of daylight and these are the best pictures I could get.

Accumulated a lot of water in a short period of time, only went 200...
Forum: General Discussion 05-05-2014, 03:08 PM
Replies: 12
Views: 486
Posted By NParkhurst
I experienced the exact same thing yesterday. ...

I experienced the exact same thing yesterday. Boat has been winterized and on the dock lift all winter, engine fired up and ran great. However I noticed forward and aft bilge pumps were activating,...
Forum: Towers 06-26-2012, 10:38 AM
Replies: 11
Views: 2,245
Posted By NParkhurst
Found it @ www.wakeboards.com, same folks @...

Found it @ www.wakeboards.com, same folks @ waterskis.com.

http://www.wakeboards.com/MasterCraft-Wakeboard-Tower-Navigation-Light-p/tower_navigation_light_02-07.htm

$30 buck including...
Forum: Towers 06-25-2012, 10:48 AM
Replies: 11
Views: 2,245
Posted By NParkhurst
Just contacted Zero Flex, who manufactured the...

Just contacted Zero Flex, who manufactured the towers in 04, but not in 06.

They mentioned a company called "Gere Marie" that was the OEM in 2006.

I'll update once I've talked to them.
Forum: Towers 06-25-2012, 10:25 AM
Replies: 11
Views: 2,245
Posted By NParkhurst
2006 X-1 Tower Nav Light?

I have a 2006 X-1 with factory tower (manufacturer?), and the navigation light that sits on top of the tower has broken.

Specifically the plastic housing that holds the navigation bulb in...
Forum: Audio/Stereo 05-24-2012, 03:54 PM
Replies: 5
Views: 722
Posted By NParkhurst
I dont have left right control over the tower...

I dont have left right control over the tower speakers, but both of them are working.

When I noticed the issue, I double checked the balance and it was centered.

I know its hard to diagnose, with...
Forum: Audio/Stereo 05-24-2012, 03:47 PM
Replies: 5
Views: 722
Posted By NParkhurst
After further contemplation.... I believe the...

After further contemplation....

I believe the tower speakers and sub are run off the amp, so that might answer why the tower speakers and sub work.

Also, I believe the cabin speakers are run off...
Forum: Audio/Stereo 05-24-2012, 03:19 PM
Replies: 5
Views: 722
Posted By NParkhurst
Left Speakers Not Working

I have an 06' X-1 with stock stereo system, amp and tower speakers.

All speakers work (Right Front, Right Rear, Sub, Right Tower, Left Tower) except for the Left Front, and Left Rear speakers.

I...
Forum: General Discussion 05-18-2012, 03:06 PM
Replies: 3
Views: 592
Posted By NParkhurst
Thanks for the feedback! I don't have a problem...

Thanks for the feedback!

I don't have a problem hauling to Seymour for a good mechanic.

My '06 X1 has had very few issues and I'd like to keep it that way with preventive maintenance.
Forum: General Discussion 05-17-2012, 02:09 PM
Replies: 3
Views: 592
Posted By NParkhurst
Recommended mechanic in Knoxville area?

Does anyone have a recommended MC mechanic in the Knoxville area?

Preferrably someone that will service on the water, but I don't have an issue trailering if I have to.

I will not take the boat to...
Forum: General Discussion 05-13-2010, 11:22 PM
Replies: 18
Views: 5,317
Posted By NParkhurst
I checked the breaker when I first noticed it...

I checked the breaker when I first noticed it wasn't working, and it was fine. I suspect that it's getting enough power.

Assuming the pump is bad, what is recommended for getting the fix done...
Forum: General Discussion 05-13-2010, 09:28 PM
Replies: 18
Views: 5,317
Posted By NParkhurst
06 X-1 Ballast Pump Problem

Port ballast pump on my 2006 X-1 is not working. The other two pumps are activating and working properly. I don't hear the port ballast pump activate at all.

Just had it de-winterized, and the...
Forum: General Discussion 07-06-2009, 04:03 PM
Replies: 2
Views: 375
Posted By NParkhurst
The mechanic checked the strainer on intake side,...

The mechanic checked the strainer on intake side, and everything was clean.

I'm dropping it off at the MC Dealer today (Cleveland Boat Center, TN).

Will update what they. Not very happy about...
Forum: General Discussion 07-06-2009, 01:51 PM
Replies: 2
Views: 375
Posted By NParkhurst
'06 X-1 Temperature Problem?

This past Thursday, July 2nd we took our recently purchased 2006 x-1 out for a evening session.

We got one ride in and the temp alarm went off reading "TEMP 206".

Immediately shut everything down,...
Showing results 1 to 17 of 17

 

All times are GMT -4. The time now is 01:45 PM.