Go Back   TeamTalk > Search Forums

Showing results 1 to 15 of 15
Search took 0.00 seconds.
Search: Posts Made By: quallsdw
Forum: Electrical 09-06-2011, 12:16 PM
Replies: 28
Views: 3,463
Posted By quallsdw
willski, that does sound pretty similar to mine. ...

willski, that does sound pretty similar to mine. My switches never stopped working though... it sounds like maybe your electrical sending unit may be bad? Maybe the alternator? My only issue...
Forum: Engine / Drive Train 08-29-2011, 05:22 PM
Replies: 1
Views: 455
Posted By quallsdw
Question '02 X-Star: Oil Dipstick Handle Broke Off

So while installing a new alternator and belt associated with it, I accidentally broke off the handle of my oil dipstick... then proceeded to push the remaining stick even further down while trying...
Forum: Electrical 08-28-2011, 04:14 PM
Replies: 28
Views: 3,463
Posted By quallsdw
Everything working great! Charged up both...

Everything working great! Charged up both batteries, and now just running on battery 1 only. Voltage staying at 13 at idle, and 14 when running. Thanks for all the help everyone.
Forum: Electrical 08-25-2011, 10:16 AM
Replies: 28
Views: 3,463
Posted By quallsdw
My thoughts exactly... I will be checking that...

My thoughts exactly... I will be checking that first thing tomorrow when I get back out there. If I can get both batteries charged back to 12 V, I think my worries will finally be over. The new...
Forum: Electrical 08-24-2011, 08:29 PM
Replies: 28
Views: 3,463
Posted By quallsdw
Unfortunately not... The manual leaves a whole...

Unfortunately not... The manual leaves a whole lot left to the imagination.
Forum: Electrical 08-24-2011, 04:58 PM
Replies: 28
Views: 3,463
Posted By quallsdw
Thanks, I will be back out there Friday and will...

Thanks, I will be back out there Friday and will give it a go. I'm going to test the charge in both batteries while cold to see what my basis is before going out. I think if I can get them both to...
Forum: Electrical 08-24-2011, 04:24 PM
Replies: 28
Views: 3,463
Posted By quallsdw
I think that's been the issue... I think the...

I think that's been the issue... I think the battery hasn't been fully charged in quite some time, due to the alternator being bad for quite some time. It registered 10.5 ish with everything off...
Forum: Electrical 08-24-2011, 01:53 PM
Replies: 28
Views: 3,463
Posted By quallsdw
Yes, the stereo does indeed go off when the alarm...

Yes, the stereo does indeed go off when the alarm comes on. I didn't know if that was the case though for any time the alarm goes on for anything.

What are all the ways the alarm can go on?

-Low...
Forum: Electrical 08-24-2011, 12:05 PM
Replies: 28
Views: 3,463
Posted By quallsdw
Thanks for the replies all, I really appreciate...

Thanks for the replies all, I really appreciate it. I agree, I don't want to kill the alarm unless I just have to. There's nothing worse than not being able to enjoy a day at the lake with the...
Forum: Electrical 08-24-2011, 11:20 AM
Replies: 28
Views: 3,463
Posted By quallsdw
Could it also be my battery that is having...

Could it also be my battery that is having trouble keeping a charge?

And back to the worst-case scenario, does anyone know how to manually disable the alarm altogether? We can't even listen to the...
Forum: Electrical 08-24-2011, 10:52 AM
Replies: 28
Views: 3,463
Posted By quallsdw
I've got the 330 HP engine. Alternator I put in...

I've got the 330 HP engine. Alternator I put in is a 70 Amp one, it basically matched the old one which was the factory one I believe. Also put a new alternator belt on.

My Optima 1000 CCA battery...
Forum: Electrical 08-24-2011, 10:41 AM
Replies: 28
Views: 3,463
Posted By quallsdw
Yeah, I think it is still something related to...

Yeah, I think it is still something related to the voltage. I did do a load test on the battery before going out, and it was at about 10.5 volts cold. I used the 1+2 switch to start the engine, and...
Forum: Electrical 08-24-2011, 09:58 AM
Replies: 28
Views: 3,463
Posted By quallsdw
Question 2002 X-Star... Alarm Won't Stop Coming On...

PLEASE HELP! My mechanic is at a loss, as am I.

The alarm keeps coming on after about 5 minutes from initial start-up. It will stay on for about another 5 minutes, then go off. Then it comes back...
Forum: Electrical 06-01-2011, 12:21 PM
Replies: 3
Views: 405
Posted By quallsdw
Thanks flipper, I actually found a thread with...

Thanks flipper, I actually found a thread with that same info from you using the search function. I am going to try that route. Thanks!
Forum: Electrical 06-01-2011, 11:55 AM
Replies: 3
Views: 405
Posted By quallsdw
Installing iPod jack to 2002 X-Star

Any ideas? Boat I just bought has a CD stereo faceplate and nothing more. No aux inputs, etc. Also has the track and volume control by the swim deck. What is the easiest way to wire up the system...
Showing results 1 to 15 of 15

 

All times are GMT -4. The time now is 05:15 AM.