Go Back   TeamTalk > Search Forums

Showing results 1 to 9 of 9
Search took 0.00 seconds.
Search: Posts Made By: skislow69
Forum: Engine / Drive Train 04-04-2014, 07:23 AM
Replies: 8
Views: 277
Posted By skislow69
Water pump check

Found out the overheat problem was due to the wrong impeller being installed when I brought in for my annual maintenance. For some reason my engine has a jabsco water pump on it instead of the...
Forum: Engine / Drive Train 03-26-2014, 10:30 PM
Replies: 8
Views: 277
Posted By skislow69
Svrider, Ok, going to try that out tonight-...

Svrider,

Ok, going to try that out tonight- thanks!
Forum: Engine / Drive Train 03-26-2014, 04:58 PM
Replies: 8
Views: 277
Posted By skislow69
no heater, unfortunately needed down here in...

no heater, unfortunately needed down here in Florida right now!
Forum: Engine / Drive Train 03-26-2014, 01:58 PM
Replies: 8
Views: 277
Posted By skislow69
It does have a pressure cap I believe, doesn't...

It does have a pressure cap I believe, doesn't seem like it's loose or anything...
Forum: Engine / Drive Train 03-26-2014, 11:56 AM
Replies: 8
Views: 277
Posted By skislow69
LY6 Saltwater series overheat

I have an 2007 CSX with the LY6 SS engine that has started to overheat. It runs on the hose for about 10-15 mins before creeping above 160. It just had an impeller change and all the fluids including...
Forum: Upholstery 04-12-2013, 09:25 AM
Replies: 34
Views: 3,758
Posted By skislow69
Interior

That looks great- how much does that run for your xstar?
Forum: Audio/Stereo 04-12-2013, 09:22 AM
Replies: 22
Views: 2,251
Posted By skislow69
Install

How hard are they to install on the factory JL speakers?
Forum: General Discussion 03-24-2013, 10:40 AM
Replies: 23
Views: 2,420
Posted By skislow69
Ok, I found out the cold start RPM fluctuation is...

Ok, I found out the cold start RPM fluctuation is normal for the LY6 engine and when I get the boat back out for the summer, I'm going to try taking a black light through the engine box. Johkur,...
Forum: General Discussion 03-23-2013, 02:57 AM
Replies: 23
Views: 2,420
Posted By skislow69
Anti-Freeze Loss

I recently bought an 07 CSXss, and have noticed that whenever I fill the Anti-Freeze to the cold line on the storage tank, it seems to go right back to the bottom, so I must lose anti-freeze...
Showing results 1 to 9 of 9

 

All times are GMT -4. The time now is 10:08 AM.