Go Back   TeamTalk > Search Forums

Showing results 1 to 25 of 122
Search took 0.01 seconds.
Search: Posts Made By: Tomi
Forum: Engine / Drive Train 07-06-2017, 09:36 AM
Replies: 3
Views: 193
Posted By Tomi
TPS voltage

Hi,

My TPS sensor is reading 0,5V at idle and 3,6 at full throttle. Looking at the car engine related topics online the values should be 0,7V-4,6V.
No gaps or anything. It is linear but on the low...
Forum: Engine / Drive Train 07-06-2017, 07:05 AM
Replies: 0
Views: 138
Posted By Tomi
IAC part number

Hi,

I need a quick replacement of IAC for RTP-1 Indmar engine. No Indmar parts available on this continent so does anyone happen to know the GM part number for one that can be used?

-Tomi
Forum: Electrical 03-24-2017, 09:24 AM
Replies: 5
Views: 650
Posted By Tomi
Thanks! Price is fine, no argument there. It...

Thanks! Price is fine, no argument there. It would just be so much easier to get one locally and avoid the customs hassle.
Does anyone have any automotive part number for this? Local US parts stores...
Forum: Electrical 03-24-2017, 02:59 AM
Replies: 5
Views: 650
Posted By Tomi
Cannot access the link, getting access...

Cannot access the link, getting access denied.

Anyway, google seems to return just dist cap for this number reference so no that is not what I am looking for. Rather...
Forum: Electrical 03-23-2017, 02:03 PM
Replies: 5
Views: 650
Posted By Tomi
Distributor for RTP1

Hi,

I need a new distributor for my 2003 Prostar RTP-1 engine. No GM marine shops here locally so before I go and order one from Skidim, does anyone know if I can use non-marine distributor for...
Forum: Electrical 05-24-2016, 02:22 PM
Replies: 12
Views: 962
Posted By Tomi
I am having exactly the same issue. My symptoms...

I am having exactly the same issue. My symptoms are occasional rough idle and occasional stall. It seems that some or all my EFI sensors + other electronics on the engine are momentarily out of...
Forum: Engine / Drive Train 10-10-2014, 08:26 AM
Replies: 29
Views: 3,233
Posted By Tomi
Engine fixed and boat is back on the water again....

Engine fixed and boat is back on the water again. Still 3-4 weeks of season remaining :)
Forum: Engine / Drive Train 10-03-2014, 12:16 PM
Replies: 29
Views: 3,233
Posted By Tomi
Indeed! Pretty impressive. Pinpoint accuracy.

Indeed! Pretty impressive. Pinpoint accuracy.
Forum: Engine / Drive Train 10-03-2014, 07:33 AM
Replies: 29
Views: 3,233
Posted By Tomi
I am not original owner but at least on my use it...

I am not original owner but at least on my use it has never overheated. I did have electric connector issues with starboard side fuel injector and that caused some running issues for a little while...
Forum: Engine / Drive Train 10-03-2014, 05:23 AM
Replies: 29
Views: 3,233
Posted By Tomi
Only 440hrs on the engine? Both sides showing...

Only 440hrs on the engine? Both sides showing same symptoms. One would think this is not only my engine? Any ideas on the root cause or similar experiences?
Forum: Engine / Drive Train 10-03-2014, 05:20 AM
Replies: 29
Views: 3,233
Posted By Tomi
Issue is identified.... head gasket. On one side...

Issue is identified.... head gasket. On one side there is a burned bridge between two middle cylinders and on the other side exactly on the same place a similar issue developing but not through yet.
Forum: Engine / Drive Train 09-26-2014, 04:13 AM
Replies: 29
Views: 3,233
Posted By Tomi
Update: Two cylinders in starboard side have no...

Update:
Two cylinders in starboard side have no compression. Next week we shall see what is the cause...
Forum: Engine / Drive Train 09-17-2014, 01:33 PM
Replies: 29
Views: 3,233
Posted By Tomi
An update: * Oil both in engine and tranny seem...

An update:
* Oil both in engine and tranny seem ok -> will change to mineral oil to test if lower viscosity oil makes a difference. Tranny is still under consideration also. I read that it could also...
Forum: Engine / Drive Train 09-11-2014, 10:08 AM
Replies: 29
Views: 3,233
Posted By Tomi
Here is video to clarify the...

Here is video to clarify the issue:
https://www.youtube.com/watch?v=mJODUqlPJpc
Forum: Engine / Drive Train 09-11-2014, 02:05 AM
Replies: 29
Views: 3,233
Posted By Tomi
Ok. That sort of makes sense. How to be sure? Is...

Ok. That sort of makes sense. How to be sure? Is it still safe to ski till end of season?

There is no audible noise when idling on gear or going steady at 1000+ rpm (cruise back from lake after...
Forum: Engine / Drive Train 09-10-2014, 03:00 PM
Replies: 14
Views: 2,416
Posted By Tomi
Just incase someone has same issues mine was...

Just incase someone has same issues mine was finally pretty clear. One of the injectors connector was not tight enough and injector lost connection. It was an easy fix by opening the connector and...
Forum: Engine / Drive Train 09-10-2014, 02:58 PM
Replies: 29
Views: 3,233
Posted By Tomi
Loud engine noise under load

Hi,

2003 Indmar RTP-1 engine on Prostar 190. Suddenly today the engine started to make relatively loud clanging noise when accelerating. The noise comes at around 2000 rpm. No idea if it would go...
Forum: Engine / Drive Train 06-05-2013, 03:35 PM
Replies: 14
Views: 2,416
Posted By Tomi
Link to the...

Link to the video:
http://www.youtube.com/watch?v=SjUQM35hg9k&feature=youtu.be
Forum: Engine / Drive Train 06-05-2013, 03:08 PM
Replies: 14
Views: 2,416
Posted By Tomi
Today went through the engine and checked all...

Today went through the engine and checked all plugs. No issues. Found some old impeller pieces in the transmission cooler that I removed. Cleared ECM and filled up with new gas.

No real change,...
Forum: Engine / Drive Train 06-03-2013, 02:25 PM
Replies: 14
Views: 2,416
Posted By Tomi
I did not reset the ECM or re-read the codes!...

I did not reset the ECM or re-read the codes! Stupid me...

Will do this tomorrow. It is near night time in Finland and I am already back home but the boat it at the marina.
Forum: Engine / Drive Train 06-03-2013, 02:11 PM
Replies: 14
Views: 2,416
Posted By Tomi
I have never seen the temp to rise over 160. The...

I have never seen the temp to rise over 160. The engine has closed cooling system if it makes any difference.

Check engine light does come at the same time. No buzzers.
Forum: Engine / Drive Train 06-03-2013, 02:04 PM
Replies: 14
Views: 2,416
Posted By Tomi
Ok, fixed the pump placement and throttle...

Ok, fixed the pump placement and throttle linkage.

The engine runs perfectly until it is run hot. The temperature gauge sits steadily at 160 and oil pressure is good. But once loaded and hot, it...
Forum: Engine / Drive Train 06-03-2013, 08:18 AM
Replies: 14
Views: 2,416
Posted By Tomi
Thanks! Both fuel pump and TPS listed in the 81...

Thanks! Both fuel pump and TPS listed in the 81 code possibilities. Sounds like I need to proceed with my initial fix issue list for pump and throttle lever and see if that fixes the problems.
Forum: Engine / Drive Train 06-03-2013, 07:18 AM
Replies: 14
Views: 2,416
Posted By Tomi
Oh, and the boat is 2003 Prostar with RTP-1 5,7...

Oh, and the boat is 2003 Prostar with RTP-1 5,7 EFI engine
Forum: Engine / Drive Train 06-03-2013, 07:17 AM
Replies: 14
Views: 2,416
Posted By Tomi
DLC code 81? Engine issues

Hi,

I am having issues where my engine seems to loose power, check light comes on and engine refuses to rev, sputters with hissing sound, run erratically and sometimes shuts down at idle once the...
Showing results 1 to 25 of 122

 

All times are GMT -4. The time now is 03:10 PM.