Go Back   TeamTalk > Search Forums

Showing results 1 to 5 of 5
Search took 0.09 seconds.
Search: Posts Made By: Krejci76
Forum: Trailers 07-29-2010, 10:50 PM
Replies: 26
Views: 3,306
Posted By Krejci76
It is a 2004 red trailer for an x-star. The guy...

It is a 2004 red trailer for an x-star. The guy that sold me the boat said he had recently changed the tires but this was untrue. the tired were 7 years old, I am going to change them all. Thats...
Forum: Trailers 07-26-2010, 11:59 PM
Replies: 26
Views: 3,306
Posted By Krejci76
I have had the exact same thing happen on my...

I have had the exact same thing happen on my trailer twice. The replacement fender was $800 and then it happened again on the other side. I guess I'll have to buy another fender. My broken fenders...
Forum: General Discussion 07-26-2010, 10:37 PM
Replies: 3
Views: 2,009
Posted By Krejci76
It is a 2004 x-star. There is not a mastercraft...

It is a 2004 x-star. There is not a mastercraft dealer in Kansas City. I am the second owner and the boat is from Nebraska water sports. I have replaced one impeller. I will try the hand crank...
Forum: General Discussion 07-26-2010, 08:58 PM
Replies: 3
Views: 2,009
Posted By Krejci76
Ballast Pumps Making No Noise and Not Working

My ballast punps were all working when the KGB ballast started working sporadically. It quit working at all, but the port and STBD ballast still worked fine. A few hours later they all quit...
Forum: General Discussion 07-26-2010, 01:11 PM
Replies: 1
Views: 2,236
Posted By Krejci76
Did you ever figure this out? I am having the...

Did you ever figure this out? I am having the exact same problem. My KGB ballast was working sporadically and then just quit. The next time out the two other ballasts pumps quit responding at all....
Showing results 1 to 5 of 5

 

All times are GMT -4. The time now is 03:44 AM.