Go Back   TeamTalk > Search Forums

Showing results 1 to 25 of 109
Search took 0.01 seconds.
Search: Posts Made By: musicmd
Forum: General Discussion 06-06-2014, 05:48 PM
Replies: 19
Views: 1,010
Posted By musicmd
Thanks to all for the responses. This is a great...

Thanks to all for the responses. This is a great help.

I'll try to get to a few of these places and report back.
Forum: General Discussion 05-22-2014, 09:46 AM
Replies: 19
Views: 1,010
Posted By musicmd
Wisconsin Lakes

Well, the X-10 is out of storage and "summarized" and my whole family is looking forward to the upcoming watersports season.

I do have a question for those who know a bit about Wisconsin lakes . ....
Forum: Engine / Drive Train 08-31-2013, 09:21 AM
Replies: 16
Views: 815
Posted By musicmd
Sorry for the delay in getting back. Life has...

Sorry for the delay in getting back. Life has been crazy and I've been unable to get pics or post an update until today. I wanted the boat for Labor Day weekend and actually ended up taking it to...
Forum: Engine / Drive Train 08-27-2013, 03:58 PM
Replies: 16
Views: 815
Posted By musicmd
Oil mixed in bilge

I have a 2004 X-10 which has been working great this Summer.

Recently, over the past 2 weeks, I've noticed an oily film on the drain plug in the middle of the hull. In addition, the water which...
Forum: Trailers 08-24-2013, 09:47 AM
Replies: 23
Views: 1,379
Posted By musicmd
Thanks to all the great responses. I've made the...

Thanks to all the great responses. I've made the decision to do the caliper replacement myself, as it is clear that the starboard side wheel is not turning freely. Thanks, also, bturner, for the...
Forum: Trailers 08-22-2013, 08:19 PM
Replies: 23
Views: 1,379
Posted By musicmd
Thanks to everyone for their input on this. I'm...

Thanks to everyone for their input on this. I'm pretty sure this trailer has original parts from 2004, due to the fact it was rarely used. So, it may be that it is a caliper problem, especially...
Forum: Trailers 08-21-2013, 10:53 PM
Replies: 23
Views: 1,379
Posted By musicmd
I had a chance to check the tongue and coupler...

I had a chance to check the tongue and coupler more carefully this evening. It does seem that the coupler is all the way out. The shock absorber seems to be fully extended - - - it can only...
Forum: Trailers 08-20-2013, 10:31 PM
Replies: 23
Views: 1,379
Posted By musicmd
I'll try to snap a few photos tomorrow to show...

I'll try to snap a few photos tomorrow to show what I'm seeing.
Forum: Trailers 08-20-2013, 10:30 PM
Replies: 23
Views: 1,379
Posted By musicmd
Thanks for the help. I had a few minutes to look...

Thanks for the help. I had a few minutes to look closely at the tongue and see what people mean by the "coupler being pushed into the tongue." This, indeed, seems to be the issue, as the coupler is...
Forum: Trailers 08-19-2013, 03:38 PM
Replies: 23
Views: 1,379
Posted By musicmd
You're correct. I push it into the garage by...

You're correct. I push it into the garage by pushing on the bow of the boat.

My tongue doesn't look like the one in Rockman's pic, FWIW. Mine is a fold-away with a chrome coupler.

I've done...
Forum: Trailers 08-19-2013, 01:38 PM
Replies: 23
Views: 1,379
Posted By musicmd
I haven't done anything except take the trailer...

I haven't done anything except take the trailer tongue off the ball, fold the tongue back, then lower the tongue all the way down before pushing the trailer back in.

How do I go about "pulling the...
Forum: Trailers 08-18-2013, 11:39 PM
Replies: 23
Views: 1,379
Posted By musicmd
Brakes engage when pushing boat in and out of garage

So, I'm hoping there is an easy fix/solution to this issue. My trailer seems to work great when I'm towing, both forward and backward. I don't feel the brakes engaging when I don't want them to and...
Forum: Tow Vehicles 07-27-2013, 06:57 PM
Replies: 5,036
Views: 888,821
Posted By musicmd
Just got the boat and the new Nissan Xterra out...

Just got the boat and the new Nissan Xterra out for the "maiden" voyage. The new rig did great and I'm happy with the look, as well.
Forum: Tow Vehicles 07-22-2013, 09:52 AM
Replies: 5,036
Views: 888,821
Posted By musicmd
Just took ownership of a 2013 Nissan Xterra...

Just took ownership of a 2013 Nissan Xterra Pro-4X this weekend, which will replace my Honda Pilot as the tow vehicle. The Pilot did fine, although it sometimes felt like it was right at the edge of...
Forum: Electrical 07-01-2013, 09:00 AM
Replies: 21
Views: 2,624
Posted By musicmd
Well, yesterday, the temp sensor was working,...

Well, yesterday, the temp sensor was working, showing 74-75 degrees (which matches the local reported temps.) Whatever was causing the earlier problem now seems to be gone, at least for now.
Forum: General / Other 07-01-2013, 08:59 AM
Replies: 8
Views: 877
Posted By musicmd
Strangely enough, yesterday the water temp was...

Strangely enough, yesterday the water temp was 74-75 degrees, which fits the local measurements. Whatever was causing the earlier problem is now gone (at least for now.)
Forum: General Discussion 06-26-2013, 05:27 PM
Replies: 17
Views: 1,261
Posted By musicmd
Thanks - - - will do. We decided to hit Monona...

Thanks - - - will do. We decided to hit Monona since the wind had died down. Luckily, it worked out well for us.
Forum: General Discussion 06-24-2013, 11:17 PM
Replies: 17
Views: 1,261
Posted By musicmd
Well, that could have gone better . . .

Sunday was a big day for us - - - the first time we took the "new" 2004 X-10 out with my 20 year old step son (aka avid wakeboarder) on board. He's been out of country and this was the first time we...
Forum: Electrical 06-18-2013, 07:53 PM
Replies: 21
Views: 2,624
Posted By musicmd
I'm curious if I have a similar issue. I have a...

I'm curious if I have a similar issue. I have a 2004 X-10 - - - in my case, the lake temp is stuck on 95 degrees. I'm wondering if this could be wiring or the sensor itself?
Forum: General / Other 06-18-2013, 07:50 PM
Replies: 8
Views: 877
Posted By musicmd
I'm curious about my lake temp sensor. I have a...

I'm curious about my lake temp sensor. I have a 2004 X-10 and the lake temp is stuck on 95 degrees. Is this a result of a short somewhere or a faulty sensor?
Forum: Electrical 06-13-2013, 08:58 AM
Replies: 0
Views: 139
Posted By musicmd
2004 X-10 water temp stays at 95

I have a 2004 X-10 and the water temp is stuck on 95 degrees. (In Wisconsin, 95 degrees is considered apochryphal.)

I've read elsewhere that a "stuck" water temp often indicates a short...
Forum: General Discussion 06-01-2013, 12:25 AM
Replies: 15
Views: 1,201
Posted By musicmd
That is a thing of beauty.

That is a thing of beauty.
Forum: General Discussion 05-24-2013, 09:30 AM
Replies: 15
Views: 1,201
Posted By musicmd
Great pics. It's great to see the care and...

Great pics. It's great to see the care and quality that goes into these boats.
Forum: General Discussion 05-23-2013, 02:20 PM
Replies: 374
Views: 53,168
Posted By musicmd
Speaking only for myself, I like seeing both the...

Speaking only for myself, I like seeing both the flat ski wakes and the nice boarding wakes. My family does both; my boat pulls both.

I appreciate seeing all the great things that MC boats do.
Forum: General / Other 05-19-2013, 11:07 PM
Replies: 5,038
Views: 416,360
Posted By musicmd
Took the old MasterCraft, EFI and Wakeboard...

Took the old MasterCraft, EFI and Wakeboard Edition decals off my '04 X-10. It was really easy with a heat gun set to low (not to mention the fact that 1/3 of them were peeling off at the...
Showing results 1 to 25 of 109

 

All times are GMT -4. The time now is 07:18 AM.