Go Back   TeamTalk > Search Forums

Showing results 1 to 25 of 28
Search took 0.00 seconds.
Search: Posts Made By: goodelsha
Forum: Engine / Drive Train 07-15-2011, 09:31 AM
Replies: 5
Views: 1,709
Posted By goodelsha
I have a 2000 Prostar with the LTR motor and have...

I have a 2000 Prostar with the LTR motor and have done the paper clip test, however I used a fuse jumper instead of a paper clip. Don't know if I needed to, it just made me feal better.
Forum: Engine / Drive Train 06-28-2011, 10:36 PM
Replies: 2
Views: 787
Posted By goodelsha
JimN, I was having an issue last year with the...

JimN,

I was having an issue last year with the boat 'hunting' at idle. Fluctuating between 600 - 900 rpms or so.....I replaced the IAC and it fixed that issue. Flame arrester is clean.
Forum: Engine / Drive Train 06-28-2011, 10:34 PM
Replies: 9
Views: 1,806
Posted By goodelsha
Sorry.........thought you were talking about this...

Sorry.........thought you were talking about this when you said there was a hole under it....I know when I replace my impeller, it comes with a new gasket for the cover. Never noticed any plug or...
Forum: Engine / Drive Train 06-28-2011, 10:02 PM
Replies: 2
Views: 787
Posted By goodelsha
Bad flexplate/damper plate symptoms?

I know if springs break or are loose you will hear a rattling sound, but could it cause the motor to stall or almost stall? I have a 2000 Prostar 205V with LTR motor. This is my first MC and when I...
Forum: Engine / Drive Train 06-28-2011, 09:44 PM
Replies: 9
Views: 1,806
Posted By goodelsha
I found the same leak and replaced the...

I found the same leak and replaced the circulating pump last year. Not too difficult at all. I'm pretty sure the seals are shot once water is leaking from the weep hole. Here's a pic of mine and...
Forum: Engine / Drive Train 06-25-2011, 06:36 PM
Replies: 6
Views: 442
Posted By goodelsha
I've pulled mine off using a gear puller similar...

I've pulled mine off using a gear puller similar to this:

http://www.sears.com/shc/s/p_10153_12605_00946903000P?mv=rr&i_cntr=1309041300468
Forum: General Discussion 07-13-2010, 09:34 PM
Replies: 17
Views: 1,756
Posted By goodelsha
I took the IAC into CarQuest and they matched it...

I took the IAC into CarQuest and they matched it for me.....Part # 73-4333
Forum: Engine / Drive Train 06-11-2010, 12:38 PM
Replies: 6
Views: 531
Posted By goodelsha
I just replaced mine a month ago in my 2000 205V,...

I just replaced mine a month ago in my 2000 205V, but I don't have the P/N with me. Your dealer can get it for you, or order it online. It's located at the bottom of the fuel pump in your tank. I...
Forum: Engine / Drive Train 06-11-2010, 10:21 AM
Replies: 6
Views: 531
Posted By goodelsha
I was having this EXACT problem. Boat would...

I was having this EXACT problem. Boat would stumble and stall when I put in gear unlless I gave it more throttle..I found a bad wire at my #8 plug. Replaced it and no more stalling.
Forum: Tow Vehicles 06-07-2010, 01:22 PM
Replies: 4,681
Views: 816,708
Posted By goodelsha
Bass lake located in the Sierras.....1st time...

Bass lake located in the Sierras.....1st time there. Small lake, but who cares when you're the only one on the water! :D
Forum: General Discussion 06-07-2010, 01:17 PM
Replies: 17
Views: 1,756
Posted By goodelsha
I installed a new IAC and it solved the problem! ...

I installed a new IAC and it solved the problem! I picked it up at local autoparts store for $90Thanks for all the input and helping me get this fixed. Boat starts right up and idle's fine now.
Forum: Engine / Drive Train 06-06-2010, 10:33 AM
Replies: 2
Views: 719
Posted By goodelsha
JerryW, Thanks for the info.....unfortunately...

JerryW,

Thanks for the info.....unfortunately after reading up on the damper plate, this does sound like a possibility of what is happening with my transmission.
Forum: Tow Vehicles 06-05-2010, 06:59 PM
Replies: 4,681
Views: 816,708
Posted By goodelsha
After everyone left last weekend

After everyone left last weekend
Forum: Engine / Drive Train 06-05-2010, 01:24 AM
Replies: 2
Views: 719
Posted By goodelsha
Transmission Rattles in gear

I picked up a 2000 Prostar 205v last year, and I noticed a rattle when I put in forward or reverse, so when I checked the oil level, I found water in the transmission fluid. I pressure tested the...
Forum: General Discussion 05-28-2010, 11:22 PM
Replies: 7
Views: 1,085
Posted By goodelsha
I just replaced mine about 2 weeks ago for the...

I just replaced mine about 2 weeks ago for the 1st time...I have a 2000 Prostar 205V, and was able to get to it w/out any problems, no special tools needed....I left the 2 orange fuel lines attached,...
Forum: Trailers 05-21-2010, 09:19 AM
Replies: 8
Views: 496
Posted By goodelsha
I recently noticed one of my wheels looks...

I recently noticed one of my wheels looks slightly foward on my fender, after launching the boat last week, I looked at the wheel, everything looked normal w/out the boat on it. Leads me to believe...
Forum: Appearance 05-16-2010, 12:11 AM
Replies: 41
Views: 6,139
Posted By goodelsha
The new MC decal looks waaaaaaay better!! Great...

The new MC decal looks waaaaaaay better!! Great job!
Forum: General Discussion 05-14-2010, 07:54 PM
Replies: 17
Views: 1,756
Posted By goodelsha
This week I replaced the fuel filter, syphoned...

This week I replaced the fuel filter, syphoned the gas out, and pumpped in 28 gal of 91. I took it to the lake for a test run, and it did not idle very well. It would stumble and stall....the only...
Forum: General Discussion 05-02-2010, 12:15 PM
Replies: 17
Views: 1,756
Posted By goodelsha
Voltmeter reads 12.5v at the battery w/ engine...

Voltmeter reads 12.5v at the battery w/ engine off, and jumps up to 13.9v with the boat at 1,000rmps.

Pulled the plugs and made sure they are gapped at .045 per service manual. I did notice some...
Forum: General Discussion 05-01-2010, 05:37 PM
Replies: 17
Views: 1,756
Posted By goodelsha
LTR idle problem

I just picked up a 2000 Prostar 205V with 160 hours at the end of last year...I was only able to take it out twice before storing for the winter, and boat ran great.

I de-winterized and took the...
Forum: Engine / Drive Train 04-25-2010, 12:36 AM
Replies: 8
Views: 944
Posted By goodelsha
I have a 2000 Prostar and found the same leak on...

I have a 2000 Prostar and found the same leak on my circulatin pump at the end of last season.....looks like it had been leaking for a while. I picked up another one from Skidim for $100 and had it...
Forum: General Discussion 02-23-2010, 10:53 PM
Replies: 10
Views: 918
Posted By goodelsha
Here is my 2000 205V, same Hull as the X-star,...

Here is my 2000 205V, same Hull as the X-star, with a MC tower from 2005. The owner before had it installed, but it looks like it went in without any issues.
Forum: General / Other 09-19-2009, 07:18 PM
Replies: 4,620
Views: 357,423
Posted By goodelsha
Changed the motor oil and V-drive oil this...

Changed the motor oil and V-drive oil this morning, then found water leaking from the main circulating pump.......so pulled it off and now waiting for the new one to arrive.
Forum: Underwater Running Gear 09-15-2009, 11:28 PM
Replies: 7
Views: 487
Posted By goodelsha
I just picked up the same boat.....mine has the...

I just picked up the same boat.....mine has the LTR 330 hp. I'm running the stock prop OJ 14" light-cup. Not to sure about max rpm, but I know I had it up around 47mph off the speedo. I plan to...
Forum: General Discussion 09-15-2009, 11:09 PM
Replies: 2
Views: 455
Posted By goodelsha
Perfect......currently has ATF and I have not...

Perfect......currently has ATF and I have not notice any rattle. Seems to make sense to stick with ATF. Thanks for the quick reply.
Showing results 1 to 25 of 28

 

All times are GMT -4. The time now is 12:53 AM.