Go Back   TeamTalk > Search Forums

Showing results 1 to 25 of 49
Search took 0.01 seconds.
Search: Posts Made By: towelshoot
Forum: General Discussion 08-07-2015, 03:52 PM
Replies: 175
Views: 5,729
Posted By towelshoot
I would be in for 2 sets if still available. Did...

I would be in for 2 sets if still available. Did I read $25 per? Just let me know.
Forum: General Discussion 08-04-2015, 09:45 PM
Replies: 11
Views: 277
Posted By towelshoot
pulled the fuel pump. Cleaned the screen. Not...

pulled the fuel pump. Cleaned the screen. Not much there. Not making much if any noise. Cleaned the flame arrestor. But still have the issue. Need to prime a couple times with the key to start....
Forum: General Discussion 08-03-2015, 11:23 PM
Replies: 11
Views: 277
Posted By towelshoot
now after having read more here. It does not...

now after having read more here. It does not sound like the whine is normal or a good thing. So in addition to cleaning the flame arrestor (metal mesh), I am going to pull the fuel pump and check...
Forum: General Discussion 08-03-2015, 09:46 PM
Replies: 11
Views: 277
Posted By towelshoot
I went ahead and replaced both filters. Seemed...

I went ahead and replaced both filters. Seemed to help. I also notice that it seems to start much easier when the motor cover is open and wondering if there is an airflow issue. Perhaps the flame...
Forum: General Discussion 08-03-2015, 01:23 PM
Replies: 11
Views: 277
Posted By towelshoot
Correction MikeG - I did replace my ECT when I...

Correction MikeG - I did replace my ECT when I replaced the entire circulating pump. Also, it has the problem even the first time I try to start it when cold. So it doesn't seem to get worse after...
Forum: General Discussion 08-03-2015, 01:13 PM
Replies: 11
Views: 277
Posted By towelshoot
What should the pressure read? Should the...

What should the pressure read? Should the pressure maintain after the initial prime of turning the key? If I am loosing pressure, where should I be looking?
Forum: General Discussion 08-03-2015, 01:04 PM
Replies: 11
Views: 277
Posted By towelshoot
temp seems to stay around 160 when running. I...

temp seems to stay around 160 when running. I have not noticed anything different on the temp, but will look. I have not replaced the ECT, but I have replaced the IAC and MAP Sensor in the last...
Forum: General Discussion 08-03-2015, 12:37 PM
Replies: 11
Views: 277
Posted By towelshoot
LT-1 loosing fuel prime

I have a 1995 with the LT-1. If I shut it off after running, it will start okay. However, if I let it sit just a bit - say 10 minutes. Then I can't get it to start unless I turn the key on and off...
Forum: Engine / Drive Train 07-28-2014, 12:55 PM
Replies: 3
Views: 830
Posted By towelshoot
I have a 95 with the LT1. I feel like I have...

I have a 95 with the LT1. I feel like I have plenty of power and it handles excellent and smooth. I love it - for what we do: cruising, tubing, skiing.

I have the 3 blade, and does just fine. I...
Forum: Engine / Drive Train 07-03-2014, 12:47 PM
Replies: 21
Views: 1,110
Posted By towelshoot
Well I don't know enough to give any good advice...

Well I don't know enough to give any good advice myself. All I can say is from what you described - when I had a similar problem, it turned out to be the carb mounting gasket. As it got warm, or if...
Forum: Engine / Drive Train 06-25-2014, 03:25 PM
Replies: 15
Views: 1,184
Posted By towelshoot
Mine was just 2 bolts (hex heads), and a clip on...

Mine was just 2 bolts (hex heads), and a clip on wire harness.
Forum: Engine / Drive Train 06-23-2014, 01:26 PM
Replies: 7
Views: 481
Posted By towelshoot
You may want to do some more searching on this...

You may want to do some more searching on this site. I have a 95 also, and have found many discussions on tranny sounding like it has rocks in it when going idle. But technically there is nothing...
Forum: Engine / Drive Train 06-22-2014, 12:41 PM
Replies: 15
Views: 1,184
Posted By towelshoot
Okay - short story first: Replaced and boat is...

Okay - short story first: Replaced and boat is running great again.

Now the long story. Went to buy part. The grommet, rubber nipple thingy - whatever it is called on the old was messed up. ...
Forum: Engine / Drive Train 06-21-2014, 01:05 PM
Replies: 15
Views: 1,184
Posted By towelshoot
It looks like the culprit. The rubber gasket...

It looks like the culprit. The rubber gasket thingy on it is all messed up. Probably letting air in or something. Going to get a new one right now. I'll let you know.
Forum: Engine / Drive Train 06-21-2014, 11:54 AM
Replies: 15
Views: 1,184
Posted By towelshoot
I noticed it also tends to want to bog way down...

I noticed it also tends to want to bog way down when I give it gas in idle. Can I just replace the MAP or is there any adjustments that needs to be made to a new one before installing?
Forum: Engine / Drive Train 06-21-2014, 11:32 AM
Replies: 15
Views: 1,184
Posted By towelshoot
Thanks. I will check that out. What about the...

Thanks. I will check that out. What about the other sensor? Is that the throttle sensor?
Forum: Engine / Drive Train 06-21-2014, 11:08 AM
Replies: 15
Views: 1,184
Posted By towelshoot
Lt-1 surging and not holding idle

Boat was running perfect yesterday. Wife was out and it started to race and surge when in idle. I can start it and it will idle fine for a moment, then surge up and down and then sometimes...
Forum: Engine / Drive Train 07-10-2013, 07:56 PM
Replies: 34
Views: 4,012
Posted By towelshoot
No other gasket needed other than the o-ring seal...

No other gasket needed other than the o-ring seal it comes with. Easy Peasy as long as you don't drop the screw :)
Forum: Engine / Drive Train 07-09-2013, 01:35 PM
Replies: 34
Views: 4,012
Posted By towelshoot
Mine was having trouble starting the way it...

Mine was having trouble starting the way it should. As someone posted that triggered for me was that it was acting like a carburator engine, not fuel injected. Mine is a 95 and I saw several people...
Forum: Engine / Drive Train 07-08-2013, 04:45 PM
Replies: 9
Views: 1,210
Posted By towelshoot
I picked one up at Advance for $33. It was a BWD...

I picked one up at Advance for $33. It was a BWD part number 21755. I worked perfect. I just installed it and did nothing else.
Forum: Engine / Drive Train 07-08-2013, 04:36 PM
Replies: 34
Views: 4,012
Posted By towelshoot
Fyi

I picked one up at Advance for $33. It was a BWD part number 21755. I worked perfect. I just installed it and did nothing else.
Forum: Engine / Drive Train 07-08-2013, 04:35 PM
Replies: 5
Views: 1,109
Posted By towelshoot
Fyi

I picked one up at Advance for $33. It was a BWD part number 21755. I worked perfect. I just installed it and did nothing else.
Forum: Engine / Drive Train 06-28-2013, 11:55 AM
Replies: 9
Views: 1,210
Posted By towelshoot
Don't know if you got yours fixed, but I just...

Don't know if you got yours fixed, but I just replaced my Idle Air Control IAC for $33 from Advance, and now it is working perfect again.
Forum: Engine / Drive Train 06-28-2013, 11:53 AM
Replies: 15
Views: 1,152
Posted By towelshoot
Iac

Replaced the IAC - Got it for $33 at Advance. The wiring attachment was shifted about 30 degrees compared to the original. Sorry I forgot to get the part number though. I'll post that...
Forum: Engine / Drive Train 06-27-2013, 12:46 PM
Replies: 15
Views: 1,152
Posted By towelshoot
Will do. I am taking my part with me - so thanks...

Will do. I am taking my part with me - so thanks for the head's up. Skidim has it, but they want $181. They are great for some things, but man when it comes to parts that are universal between...
Showing results 1 to 25 of 49

 

All times are GMT -4. The time now is 01:05 PM.