Go Back   TeamTalk > Search Forums

Showing results 1 to 7 of 7
Search took 0.00 seconds.
Search: Posts Made By: connormcmullin1@gmail.com
Forum: General Discussion 05-11-2013, 11:30 PM
Replies: 27
Views: 3,014
To be honest I have the 8.1L and it sucks the gas...

To be honest I have the 8.1L and it sucks the gas but really i have so much power and I love it. Yes my wallet is very thin now but it is so worth it. like in previous comments its better to have...
Forum: Wakesurfing 05-11-2013, 11:18 PM
Replies: 8
Views: 4,144
Talking Surf wave

So this might be a bit of the over kill but it is awesome! We have a 2006 X45 with the high altitude prop and the 8.1L motor. We are also goofy riders but we have the KGB filled and the Stbd Side...
Forum: Ballast 03-01-2013, 01:01 PM
Replies: 7
Views: 1,163
Put a 750lb sac in each rear and then 1200lbs...

Put a 750lb sac in each rear and then 1200lbs down the middle to the front. this does make it hard for people to walk around but its worth it when you ride behind your sexy wake!
Forum: Ballast 03-01-2013, 12:56 PM
Replies: 6
Views: 882
I just recently upgraded to the plug and play...

I just recently upgraded to the plug and play system and love it. I have 2 750lbs sacs one in each locker then they offer 2 more i think 400lbs in the front but after trial and error we have found...
Forum: Ballast 10-25-2012, 10:10 AM
Replies: 6
Views: 1,361
Ya thanks for the help we have been trying...

Ya thanks for the help we have been trying different set ups lately for wakeboarding and my wake has now been chosen to film a boardco vid. We are now running the stock ballast then 400's in the...
Forum: Ballast 10-22-2012, 01:26 PM
Replies: 6
Views: 1,361
Talking Perfect weight.

Hi I have a 2006 x45 with the 8.1 and I'm looking for any suggestions on a perfect wake. We have a 400lb sac in each locker and another in the middle but we are looking to add more weight.
Forum: Ballast 10-22-2012, 01:13 PM
Replies: 3
Views: 679
This happened to me on my 06 x45 and it happened...

This happened to me on my 06 x45 and it happened to be the alternator was not working right so the buzzing was because of low voltage so I changed the display selector and my ballast started to work....
Showing results 1 to 7 of 7

 

All times are GMT -4. The time now is 02:19 PM.