Go Back   TeamTalk > Search Forums

Showing results 1 to 13 of 13
Search took 0.00 seconds.
Search: Posts Made By: Rich-Atlanta
Forum: General Discussion 08-19-2010, 11:20 PM
Replies: 10
Views: 1,603
Posted By Rich-Atlanta
Smiller, I have a 1999 Prostar 190 with the...

Smiller, I have a 1999 Prostar 190 with the "wings" on the rudder. I shaved right trailing edge of the rudder and it works fine. Only shave a very small amount and then give it a try, you will be...
Forum: General Discussion 08-19-2010, 10:56 PM
Replies: 14
Views: 1,195
Posted By Rich-Atlanta
Water circulation

I had a problem similar to yours drove me crazy so I ended up taking in to the local dealer. The tech did all of the same things you described and no change. The problem ended up being resolved by...
Forum: General Discussion 08-19-2010, 10:45 PM
Replies: 38
Views: 4,027
Posted By Rich-Atlanta
I agree with boxman3. I have a 1999 Prostar 190...

I agree with boxman3. I have a 1999 Prostar 190 had the same problems as you. I added 1 1/2 lift blocks w/ new u-bolts. No more dragging.

Rich
Forum: General Discussion 08-19-2010, 10:14 PM
Replies: 45
Views: 6,113
Posted By Rich-Atlanta
Ouch

Sorry to hear about your boat. I hope the punks are caught. If you need a pull I'm on Alatoona (Atlanta Water Ski Club), give me a shout.

Rich
Forum: General Discussion 05-27-2009, 04:27 PM
Replies: 12
Views: 5,503
Posted By Rich-Atlanta
Check This

Cody, I had the same problem last year. The problem turned out to be the cover on the the impeller was worn on the inside and was loosing enough of its vaccume at idle to not pick up water properly....
Forum: General Discussion 09-11-2008, 01:05 PM
Replies: 69
Views: 4,549
Posted By Rich-Atlanta
Wakechic, I am having the same problems you have...

Wakechic, I am having the same problems you have described. Did you find the gear, if so where? A part number would be great. Thanks, Rich
Forum: General Discussion 09-11-2008, 11:56 AM
Replies: 9
Views: 684
Posted By Rich-Atlanta
I purchased my PS 190 from Red Line Watersports...

I purchased my PS 190 from Red Line Watersports in Madison, WI they disclosed all service records good and bad.
Forum: Find A Pull / Give a Pull 06-27-2008, 01:00 PM
Replies: 15
Views: 1,262
Posted By Rich-Atlanta
Alatoona is almost as busy as Lanier on the...

Alatoona is almost as busy as Lanier on the weekends the only good water is before 9am or after 7pm. Monday through Thursday is great until about about 11am. One other consideration for Alatoona is...
Forum: General Discussion 06-27-2008, 12:40 PM
Replies: 8
Views: 1,070
Posted By Rich-Atlanta
I have to agree with Ted NAPA has one of the best...

I have to agree with Ted NAPA has one of the best filters around.
Forum: Underwater Running Gear 06-27-2008, 12:25 PM
Replies: 8
Views: 685
Posted By Rich-Atlanta
I just put a ACME 3 blade 13x13 on my 99 Prostar...

I just put a ACME 3 blade 13x13 on my 99 Prostar gained about 4 MPH on the top and the hole shot and holding power is outstanding
Forum: Engine / Drive Train 06-27-2008, 12:12 PM
Replies: 10
Views: 1,351
Posted By Rich-Atlanta
1999 Prostar 190

My 99 has a 31 gallon cell.
Forum: General / Other 06-06-2008, 02:03 PM
Replies: 13
Views: 1,038
Posted By Rich-Atlanta
Brent, just check for signs of wear on the inside...

Brent, just check for signs of wear on the inside cover, if it is worn replacing it may fix your issue. Rich
Forum: General / Other 06-04-2008, 04:40 PM
Replies: 13
Views: 1,038
Posted By Rich-Atlanta
Brent, I had the same problem you are describing...

Brent, I had the same problem you are describing with my 99 Prostar. I checked everything, replaced the impeller, thermostat, pulled all of the hoses and still had the overheating at idle problem. ...
Showing results 1 to 13 of 13

 

All times are GMT -4. The time now is 01:28 AM.