Go Back   TeamTalk > Search Forums

Showing results 1 to 6 of 6
Search took 0.00 seconds.
Search: Posts Made By: marshaje
Forum: Electrical 05-04-2015, 08:35 AM
Replies: 2
Views: 161
Posted By marshaje
yea I think so.... that could explain the...

yea I think so.... that could explain the overheating that suddenly occurred ...
Forum: Electrical 05-04-2015, 07:43 AM
Replies: 2
Views: 161
Posted By marshaje
Unhappy 2008 Xstar starter making a vacuum noise

Hey guys, I bought an 2008 x-star a year and a half ago with a new motor installed in 2013. So I was coming home from a day at the lake and I noticed that the engine was getting really hot. It got...
Forum: General / Other 04-14-2014, 10:40 AM
Replies: 3
Views: 397
Posted By marshaje
A few symptoms that maybe you guys can help me with....

I have an 08' Xstar with a new motor. Well the engine was put in last season so I have about 10-20 hrs on it.

Symptom 1: Starter Fuse has blown twice since I have had it. A fuse is easy to...
Forum: Electrical 02-13-2014, 04:19 PM
Replies: 14
Views: 2,481
Posted By marshaje
Yes I would really love some photos of how you...

Yes I would really love some photos of how you ran the wire and how you stuck it to the underside of your platform. I would prefer not to drill any holes... for obvious reasons.
Forum: Engine / Drive Train 09-27-2013, 08:34 AM
Replies: 1
Views: 526
Posted By marshaje
It was a blown fuse.... I am such a newbie when...

It was a blown fuse.... I am such a newbie when it comes to boats.
Forum: Engine / Drive Train 09-23-2013, 08:15 AM
Replies: 1
Views: 526
Posted By marshaje
Starting issues

Hey guys, I am going to get this fixed by the dealer but I wanted to get thoughts from all of you. I have an 08 Xstar with a brand new motor in it. I mean it had 2 hours on it when I bought it. ...
Showing results 1 to 6 of 6

 

All times are GMT -4. The time now is 01:56 AM.