Go Back   TeamTalk > Search Forums

Showing results 1 to 25 of 116
Search took 0.03 seconds.
Search: Posts Made By: Tomi
Forum: Engine / Drive Train 10-10-2014, 08:26 AM
Replies: 29
Views: 1,458
Posted By Tomi
Engine fixed and boat is back on the water again....

Engine fixed and boat is back on the water again. Still 3-4 weeks of season remaining :)
Forum: Engine / Drive Train 10-03-2014, 12:16 PM
Replies: 29
Views: 1,458
Posted By Tomi
Indeed! Pretty impressive. Pinpoint accuracy.

Indeed! Pretty impressive. Pinpoint accuracy.
Forum: Engine / Drive Train 10-03-2014, 07:33 AM
Replies: 29
Views: 1,458
Posted By Tomi
I am not original owner but at least on my use it...

I am not original owner but at least on my use it has never overheated. I did have electric connector issues with starboard side fuel injector and that caused some running issues for a little while...
Forum: Engine / Drive Train 10-03-2014, 05:23 AM
Replies: 29
Views: 1,458
Posted By Tomi
Only 440hrs on the engine? Both sides showing...

Only 440hrs on the engine? Both sides showing same symptoms. One would think this is not only my engine? Any ideas on the root cause or similar experiences?
Forum: Engine / Drive Train 10-03-2014, 05:20 AM
Replies: 29
Views: 1,458
Posted By Tomi
Issue is identified.... head gasket. On one side...

Issue is identified.... head gasket. On one side there is a burned bridge between two middle cylinders and on the other side exactly on the same place a similar issue developing but not through yet.
Forum: Engine / Drive Train 09-26-2014, 04:13 AM
Replies: 29
Views: 1,458
Posted By Tomi
Update: Two cylinders in starboard side have no...

Update:
Two cylinders in starboard side have no compression. Next week we shall see what is the cause...
Forum: Engine / Drive Train 09-17-2014, 01:33 PM
Replies: 29
Views: 1,458
Posted By Tomi
An update: * Oil both in engine and tranny seem...

An update:
* Oil both in engine and tranny seem ok -> will change to mineral oil to test if lower viscosity oil makes a difference. Tranny is still under consideration also. I read that it could also...
Forum: Engine / Drive Train 09-11-2014, 10:08 AM
Replies: 29
Views: 1,458
Posted By Tomi
Here is video to clarify the...

Here is video to clarify the issue:
https://www.youtube.com/watch?v=mJODUqlPJpc
Forum: Engine / Drive Train 09-11-2014, 02:05 AM
Replies: 29
Views: 1,458
Posted By Tomi
Ok. That sort of makes sense. How to be sure? Is...

Ok. That sort of makes sense. How to be sure? Is it still safe to ski till end of season?

There is no audible noise when idling on gear or going steady at 1000+ rpm (cruise back from lake after...
Forum: Engine / Drive Train 09-10-2014, 03:00 PM
Replies: 14
Views: 1,035
Posted By Tomi
Just incase someone has same issues mine was...

Just incase someone has same issues mine was finally pretty clear. One of the injectors connector was not tight enough and injector lost connection. It was an easy fix by opening the connector and...
Forum: Engine / Drive Train 09-10-2014, 02:58 PM
Replies: 29
Views: 1,458
Posted By Tomi
Loud engine noise under load

Hi,

2003 Indmar RTP-1 engine on Prostar 190. Suddenly today the engine started to make relatively loud clanging noise when accelerating. The noise comes at around 2000 rpm. No idea if it would go...
Forum: Engine / Drive Train 06-05-2013, 03:35 PM
Replies: 14
Views: 1,035
Posted By Tomi
Link to the...

Link to the video:
http://www.youtube.com/watch?v=SjUQM35hg9k&feature=youtu.be
Forum: Engine / Drive Train 06-05-2013, 03:08 PM
Replies: 14
Views: 1,035
Posted By Tomi
Today went through the engine and checked all...

Today went through the engine and checked all plugs. No issues. Found some old impeller pieces in the transmission cooler that I removed. Cleared ECM and filled up with new gas.

No real change,...
Forum: Engine / Drive Train 06-03-2013, 02:25 PM
Replies: 14
Views: 1,035
Posted By Tomi
I did not reset the ECM or re-read the codes!...

I did not reset the ECM or re-read the codes! Stupid me...

Will do this tomorrow. It is near night time in Finland and I am already back home but the boat it at the marina.
Forum: Engine / Drive Train 06-03-2013, 02:11 PM
Replies: 14
Views: 1,035
Posted By Tomi
I have never seen the temp to rise over 160. The...

I have never seen the temp to rise over 160. The engine has closed cooling system if it makes any difference.

Check engine light does come at the same time. No buzzers.
Forum: Engine / Drive Train 06-03-2013, 02:04 PM
Replies: 14
Views: 1,035
Posted By Tomi
Ok, fixed the pump placement and throttle...

Ok, fixed the pump placement and throttle linkage.

The engine runs perfectly until it is run hot. The temperature gauge sits steadily at 160 and oil pressure is good. But once loaded and hot, it...
Forum: Engine / Drive Train 06-03-2013, 08:18 AM
Replies: 14
Views: 1,035
Posted By Tomi
Thanks! Both fuel pump and TPS listed in the 81...

Thanks! Both fuel pump and TPS listed in the 81 code possibilities. Sounds like I need to proceed with my initial fix issue list for pump and throttle lever and see if that fixes the problems.
Forum: Engine / Drive Train 06-03-2013, 07:18 AM
Replies: 14
Views: 1,035
Posted By Tomi
Oh, and the boat is 2003 Prostar with RTP-1 5,7...

Oh, and the boat is 2003 Prostar with RTP-1 5,7 EFI engine
Forum: Engine / Drive Train 06-03-2013, 07:17 AM
Replies: 14
Views: 1,035
Posted By Tomi
DLC code 81? Engine issues

Hi,

I am having issues where my engine seems to loose power, check light comes on and engine refuses to rev, sputters with hissing sound, run erratically and sometimes shuts down at idle once the...
Forum: General Discussion 07-17-2012, 04:00 AM
Replies: 26
Views: 1,625
Posted By Tomi
Northern Europe has been less fortunate this...

Northern Europe has been less fortunate this summer. Our lake (30k acres) is still at 64 and likely will not get any better this year.
Forum: General / Other 07-11-2012, 01:14 PM
Replies: 33
Views: 4,459
Posted By Tomi
I had similar symptoms, thought I would need...

I had similar symptoms, thought I would need additional return spring also but turned out that just lubricating the cable was enough.
Forum: Engine / Drive Train 06-24-2012, 12:00 PM
Replies: 1
Views: 322
Posted By Tomi
Engine noise and fuel consumption

Run out of gas on my day at the lakes few days ago. The boat is new to me so, I don't really have a good reference but fuel consumption seemed higher that expected. The boat is Prostar 190 with RTP-1...
Forum: Electrical 06-15-2012, 06:40 AM
Replies: 1
Views: 434
Posted By Tomi
Problem found... one of the connectors behind the...

Problem found... one of the connectors behind the firewall was loose (like almost completely off). I must have pulled the wire bundles too hard at some point of the restoration. Weird enough, most...
Forum: General / Other 06-14-2012, 05:38 PM
Replies: 6
Views: 810
Posted By Tomi
Per OJ in some other thread, since 2003 all have...

Per OJ in some other thread, since 2003 all have 1 1/8" shafts, also 1:1. I also measured it a few times, so shaft is surely 1 1/8".
Forum: General / Other 06-14-2012, 08:38 AM
Replies: 6
Views: 810
Posted By Tomi
Packing related questions

2003 Prostar 190... 1:1 transmission and 5,7 RTP-1, it has 1 1/8" shaft and packing was leaking. So I took the usual route and ordered 3/16" graphite seal from Skidim. Started to replace when I...
Showing results 1 to 25 of 116

 

All times are GMT -4. The time now is 07:16 AM.