TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   Engine / Drive Train (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=24)
-   -   LT1/LTR Crank Position Sensors (http://www.mastercraft.com/teamtalk/showthread.php?t=58122)

gsxrjtt 11-09-2013 01:07 PM

LT1/LTR Crank Position Sensors
 
2 Attachment(s)
Ok so my motor is in ready to go and turning over and has come down to the crank position sensors. There are 2 in the motor only made from 93-94 .. I have looked and looked even the guys at Bay Area Watersports do not know where to get these. They are old stock part that are not made by ilmore any more. Yes I have checked the regular lt1 sensors do not work..I need to find these or find an 93-94 lt1 motor that is of no use to any one and willing to sell the sensors I have attached a pic of the exact part I need x2. Please ask around or let me know of anything.. This is the only part I need to get this boat back to running.

Attachment 102933
Attachment 102934


Sent from my iPhone using Tapatalk

mikeg205 11-09-2013 01:29 PM

1 Attachment(s)
Try www.rockauto.com these look close - maybe they can find a cross reference...

http://www.rockauto.com/catalog/more...991&cc=1041332

mikeg205 11-09-2013 01:34 PM

1 Attachment(s)
Quote:

Originally Posted by mikeg205 (Post 990721)
Try www.rockauto.com these look close - maybe they can find a cross reference...

http://www.rockauto.com/catalog/more...991&cc=1041332

here's another link... I believe this is what many on corvette forums are getting.

http://forums.corvetteforum.com/c4-t...nk-sensor.html

1redTA 11-09-2013 01:45 PM

I use to use these guys. Great prices and service

http://www.samtaylor.com/

jafo9 11-09-2013 01:46 PM

those look remarkably like the CPS on my 02 LTR. Are yours pressed into a bracket? If so, how the heck did you get them out of the bracket?

gsxrjtt 11-09-2013 03:14 PM

1 Attachment(s)
Already been that rout and I bought them they are not the same .. The problem is it was an only marine part made from ilmore and no cross reference for automotive part

Attachment 102937


Sent from my iPhone using Tapatalk

mikeg205 11-09-2013 03:28 PM

Quote:

Originally Posted by gsxrjtt (Post 990736)
Already been that rout and I bought them they are not the same .. The problem is it was an only marine part made from ilmore and no cross reference for automotive part

Attachment 102937


Sent from my iPhone using Tapatalk

intellek is a delphi part not ilmore - but maybe made to ilmore spec?

mikeg205 11-09-2013 03:32 PM

I'll ask chuck over at Indmar... he's really good at getting back to me.

gsxrjtt 11-09-2013 03:34 PM

That would be awesome thanks

mikeg205 11-09-2013 03:38 PM

Quote:

Originally Posted by gsxrjtt (Post 990741)
That would be awesome thanks

I wonder what's different on the similar parts - must be a signal change or something simple I guess. Did you talk to Ilmor?


All times are GMT -4. The time now is 04:41 AM.