TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   Restorations and Refurbishments (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=62)
-   -   Bought a 94' Prostar 205 - fix up thread (http://www.mastercraft.com/teamtalk/showthread.php?t=57628)

bochnak 09-29-2013 03:52 PM

Bought a 94' Prostar 205 - fix up thread
 
Hi,

My name is Matt and just recently joined this forum. My in laws just picked up a lakehouse and we all decided to chip in for a ski boat. I used to go boating all the time in my 20's, and that kind of came to an end when I got married and started having kids. Kids are now ages 6, 4.5, & 2.5.

The lake is 162 acres or so and is glass all day long. On busy days, I see about 3 boats out, and usually only one of them actually moving.

Plan is to do all the watersports: tubing, skiing, slalom, wakeboarding, & wakesurfing.

So we picked up this 94' for 9100. Asking price was 9800.

600hrs on hull
<100hrs on Jasper motor. (PO cracked block winterizing it. MC dealer installed. $4300)
3 & 4 blade props
2x single tubes
1x double tube
2 pairs of skiis
fake lake
Pull over cover


Problems I need to address:
Oil pressure gauge does not work
Thermostat gasket leaking and temp hovers at 130
Alternator is shot
Trailer surge brakes do not work
Buff & new decals
Blower hose is torn near blower motor
Gas shocks are missing for motorbox
New head unit and speakers
Keel roller



Pics:

https://lh4.googleusercontent.com/-I...o/DSC_5799.JPG

https://lh4.googleusercontent.com/-W...o/DSC_5800.JPG

https://lh5.googleusercontent.com/-K...o/DSC_5805.JPG

https://lh5.googleusercontent.com/-F...o/DSC_5806.JPG

https://lh3.googleusercontent.com/-k...o/DSC_5807.JPG

https://lh6.googleusercontent.com/-E...o/DSC_5808.JPG

https://lh3.googleusercontent.com/-Q...o/DSC_5809.JPG

https://lh5.googleusercontent.com/-B...o/DSC_5810.JPG

Double D 09-29-2013 04:25 PM

Congrats on the new boat and welcome to TT. Not sure about wakesurfing behind that thing but you picked up a great boat! I am a bit bias since I have owned one since 2001. Let me know if you have any questions and I will try to help.

If you didn't tell us the motor was changed I would have never known. Everything looks similar to my Indmar 350.

MI_Corey 09-29-2013 04:42 PM

Very nice. Definitely a good all around boat. My parents have had their '93 205 since '98 and always been happy with it. Doesn't look like it will take much to have yours in great shape. Once you start, MCOCD will kick in though. Team talk is like group therapy for it.

OHIOPRO205 09-29-2013 04:58 PM

Great Choice. Welcome to TT. I also have a 94.

scott023 09-29-2013 05:23 PM

Nice boat, congrats on the purchase.

TOO-TALL 09-29-2013 05:27 PM

Very nice

bochnak 09-30-2013 09:41 AM

Thanks, everyone!

bochnak 09-30-2013 09:50 AM

Oil Pressure Gauge

The gauge read 40psi with key on engine off and 80psi when running. PO replaced sending unit right before we showed up and did not fix problem.

Once I got it home, I ohmed out the sending unit with engine off and got 240 ohms. I also tested this at gauge and received the same value. Did the same while boat was running and recieved 100 ohms at both locations. So I assumed gauge was bad.

So I bought this gauge which is the closest match I found:

Teleflex 30180 Prism Series Boat Oil PSI Gauge

It's 95% correct, the lens and bezel is different and does not have the star on the face:

https://lh4.googleusercontent.com/-8...o/DSC_5812.JPG

madcityskier 09-30-2013 10:26 AM

Discount inboard marine will be a resource. skidim.com I'd contact them to get a catalogue sent sooner than later. They're very knowledgeable.
Nice boat, you're gonna love it.

bochnak 09-30-2013 10:31 AM

Quote:

Originally Posted by madcityskier (Post 981782)
Discount inboard marine will be a resource. skidim.com I'd contact them to get a catalogue sent sooner than later. They're very knowledgeable.
Nice boat, you're gonna love it.

Already placed an order from them. I did receive the catalog. Thanks for the info.


Thermostat

The thermostat housing was leaking, so I took it all apart and found no gasket. Also, the temp gauge hovered around 130 during water test. I took the thermostat out and dunked it in hot water. I noticed that is started to open/close at the 120 mark. I ordered a new 142 and gasket. Same hot water test with new t-stat shows open/close as advertised. So hopefully the temp will go to normal now.


All times are GMT -4. The time now is 09:25 PM.