TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   Engine / Drive Train (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=24)
-   -   2006 x 30 won't start (http://www.mastercraft.com/teamtalk/showthread.php?t=57460)

ridewakez 09-18-2013 09:58 AM

2006 x 30 won't start
 
I was towing another boat that broke down.when my boat died and now it won't start. I was thinking this could be a fuel pump issue? Any one got an idea what could be wrong?

markmcfarland 09-18-2013 10:51 AM

If it cranks but not starts, very likely. Just replaced mine in 2009 xstar. You can get a fuel pressure gauge that connects to the fuel rail and check your pressure pretty easy. Should be 50 psi. Mine was 22 psi, boat would start but not keep running.
http://www.amazon.com/Actron-CP7818-...ter+kit+actron

thatsmrmastercraft 09-18-2013 11:03 AM

Check your tether switch. Always the first thing to check on a kill/won't start.

CantRepeat 09-18-2013 11:13 AM

x2 on what Peter said and then move on to checking fuel pressure at the rail.

ridewakez 09-18-2013 02:38 PM

I did check the tether switch first thing after it happened it was in place. So I'm guessing its the fuel pump..where is the fuel pump located? I'll check the pressure..thanks for the tips!! Much appricated!

CantRepeat 09-18-2013 02:57 PM

Quote:

Originally Posted by ridewakez (Post 979191)
I did check the tether switch first thing after it happened it was in place. So I'm guessing its the fuel pump..where is the fuel pump located? I'll check the pressure..thanks for the tips!! Much appricated!

The pump is located in the fuel tank which is below the center storage well in the middle of your back seats.

You may find this thread helpful.

http://www.mastercraft.com/teamtalk/...ad.php?t=25783


All times are GMT -4. The time now is 03:56 AM.