TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   Electrical (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=23)
-   -   03 X30 fuel sending unit (http://www.mastercraft.com/teamtalk/showthread.php?t=57021)

SkiMC 08-26-2013 10:53 AM

03 X30 fuel sending unit
 
Has anyone had any issues with their gas gauge on a 03 X30 not working properly? I have been working with the local MC dealership trying to get my gas gauge fixed for the last 3 months. They have tried everything, replaced it twice, added a new part per the manufacturer of the stock sending unit and still nothing. It shows full all the time... Any suggestions would be greatly appreciated.

Thanks!

CC2MC 08-26-2013 04:31 PM

There is a thread on here about testing a sending unit. All you really need is a volt meter and it will be able to read the signal of the sending unit. More than likely it is not the gauge itself. Check out the thread below.

http://www.mastercraft.com/teamtalk/...ad.php?t=38453

SkiMC 08-26-2013 04:36 PM

03 X30 fuel sending unit
 
I will check it out. Thanks.

nickespi 08-26-2013 04:42 PM

Does yours read full all the time until it's empty?

SkiMC 08-27-2013 10:38 AM

Yes it reads full all the time. Don't know if it goes to empty when bone dry because have not let it get there yet.

mobilecascade 08-28-2013 03:26 PM

Thanks for asking as ours (02 XStar) just started doing the same thing these last few weeks, after dealer looked at it

g-Dog 08-28-2013 03:42 PM

If it's the same type of sending unit that's in my '02 205v there should be adjustment screws on the top.

http://www.centroidproducts.com/3wire.htm

CC2MC 10-16-2013 03:15 PM

SkiMC, You get this issue resolved?


All times are GMT -4. The time now is 02:52 PM.