TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   Engine / Drive Train (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=24)
-   -   Replacement LT1 Waterpump issues (http://www.mastercraft.com/teamtalk/showthread.php?t=56072)

hig 07-18-2013 09:30 PM

Replacement LT1 Waterpump issues
 
I purchased an AC Delco water pump for a 92 Corvette from Ebay and when I compared it to the original one is seemed the same. After bolting it on I'm having clearance issues with the bolts and sleeves that hold the front thermostat housing on.

On this side of the water pump the bolt just fits, there is NO room for the sleeve:

http://i871.photobucket.com/albums/a...ps5afcdcc4.jpg

On the other side of the pump there is more room but it's tight:

http://i871.photobucket.com/albums/a...pse813da84.jpg

Has anyone run into this with a replacement water pump? Am I reassembling something wrong? I'm thinking of making a 1/2" thick spacer that I can countersink a cap screw and over from that tap a hole - basically trying to move the bolts up and out some.

Any advice? Unfortunately I already got rid of the old one to compare it to closer.

Thanks, Steve

mgs96ps 07-18-2013 10:02 PM

Steve,

I just replaced my waterpump this summer and had no issues. My guess is that the pump is not seating properly on drive shaft gear.

billr 07-18-2013 10:16 PM

I had to grind one of the brackets off a little, but I can't remember which one. Mine was a replacement from a Chevy dealer. It seems that the bracket was interfering with the extra hose fitting. My can't remember sh*t is acting up.

hig 07-19-2013 07:41 AM

Here's a better pic with some notes:

http://i871.photobucket.com/albums/a...psfb1401a3.jpg


On the side pictured the bolt hits so there is no way to get the sleeve in there. Grinding will not help!!

The photo should say "THERE IS NO ROOM FOR THE SLEEVE"

Thanks, Steve

Jerseydave 07-19-2013 07:52 AM

I've never changed my pump, but from your pictures it looks like you now need a thinner wall sleeve because the new pump casting is thicker. Try a good hardware store or machine shop, take the old sleeves with you and get ones that are 1/2 the thickness. Small pipe cut to length should do the trick I think.

mgs96ps 07-19-2013 08:06 AM

I will not be with my boat until tonight where I can study my pump vs your pictures. Something does not look right to me as plate should slightly move independently from pump...(if I am remembering right). Tablerocker is the expert on this subject. Here is a couple pictures of mine for reference when I did the change in May.

mgs96ps 07-19-2013 08:14 AM

It seems to me that your plate is upside down. Is there a chance that you positioned your lower T stat housing on the plate incorrectly?

Table Rocker 07-19-2013 05:02 PM

I looked at mine and it is really close in there. I would pull the bolts, put the spacers over the bolts and see if they will thread up (taking care not to cross-thread). Also be careful when tightening, making sure it doesn't bind up too much.

Also, my plate has the dog ear taken out of it (as in mgs96ps's photos). I wonder why your plate is different.

hig 07-20-2013 06:22 PM

Thanks for all the replies. I ended up having 2 - 1/2" diameter rods made up at work with threads on both sides and I also ground some of the aluminum away where it was hitting on the water pump.

Aluminum ground where the bolt was hitting (sorry, it's the shiny spot):

http://i871.photobucket.com/albums/a...ps3f8d7ad0.jpg

Paint touched up and new 1/2" rods installed to replace the original 3/4" diameter sleeve

http://i871.photobucket.com/albums/a...ps5ecf9563.jpg

Finished product, the one side still flares out a little bit from the 1/2" rod rubbing:

http://i871.photobucket.com/albums/a...psf7ed604d.jpg

Thanks again for all the replies and if some one thinks something is assembled wrong please let me know!! I purchased the boat with the motor out and unassembled so I'm not quite sure how it goes.

Steve

mgs96ps 07-21-2013 08:24 AM

Did you figure out why you had clearance issues?


All times are GMT -4. The time now is 09:02 PM.