TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   General Discussion (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=6)
-   -   Water coming in X30 (http://www.mastercraft.com/teamtalk/showthread.php?t=54259)

uplander 05-12-2013 09:31 PM

Water coming in X30
 
I have many questions but I want to start with the ones that impact me the most. on the first test drive I was checking the middle opening in the floor where the plug is and I noticed some water so I put the bow up by driving real slow and turned on the bilge. After it pumped out I let her back down but continued to have water. I am not sure but I think I have a leak somewhere and would like to ask where I should start looking and is this normal for an 02 X30.

thanks for help

Skyskiguy 05-13-2013 12:45 AM

Does it have a heater?

willyt 05-13-2013 08:59 AM

center plug
rear plug
heater
freeze plugs on engine block
drain plugs on block
raw water pump
ballast hoses
ballast tanks
hull

TayMC197 05-13-2013 10:20 AM

Built in ice chest? That ice melts pretty quick and drains in the bilge if the plugs aren't in.

sand2snow22 05-13-2013 10:21 AM

rudder port?

uplander 05-13-2013 10:29 PM

no heater
no ice chest that I am aware of
I did call my marina and they said it could be the packing around the shaft, I plan to take it back out Wednesday night and back it in slow and look for leaks.
not sure about rudder port

ricford 05-14-2013 04:54 PM

My first guess would be shaft packing. The boat is 11 years old, that's about the life of the packing in my opinion. For a quick check, once the engine is warm pump the bilge out again, then once it starts to fill up again check if the bilge water is warm, it's engine related, cold it's coming from the lake around packing, plugs, ballast, etc.

dsword 05-14-2013 05:01 PM

Quote:

Originally Posted by uplander (Post 934887)
I have many questions but I want to start with the ones that impact me the most. on the first test drive I was checking the middle opening in the floor where the plug is and I noticed some water so I put the bow up by driving real slow and turned on the bilge. After it pumped out I let her back down but continued to have water. I am not sure but I think I have a leak somewhere and would like to ask where I should start looking and is this normal for an 02 X30.

thanks for help

How much water is some water? We usually had a couple of inches deep around the center plug in our 2007 X2. This is not usually enough for the bilge pump to pick up even if turned on manual. Did water come out of the bilge pump drain port on the side of the boat? Also if you put the bow up and the water all ran to the stern then the center bilge pump cannot get it out and the water will come back when you go flat again.

David Sword

uplander 05-14-2013 11:10 PM

hard to estimate how much water I had, it did pump out the bilge. once I pumped it out I had about 1 - 2 inches in the center hole by driver after I drove around for a bit. I am not sure I have a center bilge, I found the one in the back. going to back it in tomorrow and see if I can find leak on trailer first.

thanks for replies

pap 05-15-2013 08:22 AM

If water comes in, shouldn't it also come back out? How about fill up the bilge with a hose (shut off pump) and watch for where water leaking OUT underneath?


All times are GMT -4. The time now is 07:09 AM.