TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   Electrical (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=23)
-   -   Gauges Not Working (http://www.mastercraft.com/teamtalk/showthread.php?t=53451)

Jonb1822 04-06-2013 10:44 PM

Gauges Not Working
 
I need some help. Just got my 2011 X25 back from the dealer and they replaced the screen B.I.G. and the Viper system bc I had a constant blue screen when the key was turned on. Got the boat back and now the screen works but the guages do not. They sound like they are about to work, but do not move. Also the screen shows no readings for air or water temp, fuel, or any other readings. I'm not sure where to start or even what information to ask about at this point. If I can figure out without the dealer that would be great bc they did some other work and did a bad job. I don't want to take another 4 hour round trip if at all possible. Any suggestions would be great. Thanks!

pmikler 04-06-2013 10:58 PM

Quote:

Originally Posted by Jonb1822 (Post 922630)
I need some help. Just got my 2011 X25 back from the dealer and they replaced the screen B.I.G. and the Viper system bc I had a constant blue screen when the key was turned on. Got the boat back and now the screen works but the guages do not. They sound like they are about to work, but do not move. Also the screen shows no readings for air or water temp, fuel, or any other readings. I'm not sure where to start or even what information to ask about at this point. If I can figure out without the dealer that would be great bc they did some other work and did a bad job. I don't want to take another 4 hour round trip if at all possible. Any suggestions would be great. Thanks!

For something like that I would ask the dealer to come to me. That should have been checked out prior to giving you your boat back.

CC2MC 04-07-2013 12:25 AM

Agreed. ^^^

drb119 09-12-2013 01:36 AM

2012 X25 air temp guage
 
I just picked up a used 2012 X25. I had to have the software updated. One of the issues I had was the air temp gauge read 32, it never changed. After the update the air temp function was deleted from the options. The service rep told me MC has taken this option away. Does anyone have this option working on a 2012?

KahunaCraft 09-12-2013 11:25 AM

Gauges Not Working
 
The upgrade cleaned up some of the options that were not in use and fixed the usability of the system.

I have had some gauge issues when my battery runs low the gauges go wonky... to fix this, I switch over to both batteries and the problem goes away. Batteries run low because i'm running below 1500 rpm's or the motor is off and I have 4 pumps running plus the stereo ...plus the heater...

I'm going to add two deep cycle batteries (4 batteries total) to my boat next year so it runs the pumps better while the motor is off.

drb119 09-12-2013 12:27 PM

Msstercraft told me it is not possible to have the the sir temp gauge work with the Medellion gauges yet my 2010 X2 had the Medellion gauges and everything worked fine. Has anyone else had this same issue?
Thanks

gtbutler 09-12-2013 09:17 PM

KahunaCraft,
Know you were looking to go the Deep Cycle battery route but you might consider going with two 6volt batteries wired in series (to get your 12v). It's an old Motorhome trick for the "coach" batteries (running everything inside the MH), and is used by golf carts everywhere.

Just a thought...

KahunaCraft 09-12-2013 09:39 PM

Thanks, that makes sense, wasn't aware of that. Will take a look at that option.


All times are GMT -4. The time now is 04:19 AM.