TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   Electrical (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=23)
-   -   2006 X7 Fuses (http://www.mastercraft.com/teamtalk/showthread.php?t=53046)

skippy 03-14-2013 04:10 AM

2006 X7 Fuses
 
I had a problem with a dashboard switch breaking, the one for the nav lights / instruments.

Could not get a complete replacement here in New Zealand, but did get similar Carlson Tech switch which I took the plastic clip from to replace the broken part on the original 8 spade switch.

When I re-connected up the switch, I think I heard a pop noise and the lights controlled by that switch do not work. Everything else does.

I think I must have connected the switch wrongly. :( Testing all the wires, there is no current.

Help! Where are the fuses on the X7? I have taken the dashboard off, nothing under there. The user manual is not very helpful.

Cheers

CantRepeat 03-14-2013 08:53 AM

1 Attachment(s)
Hopefully you just tripped a circuit breaker. Your boat shouldn't have any fused switches up at by the driver.

After you double check the wiring on the switch and make sure it is indeed correctly wired. Look for a circuit panel like the one in the below photo. You just push the rubber button cover in to reset the circuit breakers.

If you did hear a pop then I would suggest really looking at the wiring and make sure none of it is burned.

skippy 03-14-2013 04:29 PM

Thanks for that. I had already looked at the manual (your pictures above). Trouble is, I cannot see anything that looks like the panel under the dash area! I found 2 possible resets on the end of the side panel (that has the throttle control on it).

Nothing else that looks like the panel above, hence my posting.

skippy 03-15-2013 02:33 AM

Breakers Located
 
After lying in the footwell, head first and feeling around on the the foot wall panel, I found them above and behind the heater on the left hand side.

Thanks for your help.


All times are GMT -4. The time now is 08:55 AM.