TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   Storage / Winterization (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=26)
-   -   Drain Plug Location (http://www.mastercraft.com/teamtalk/showthread.php?t=51898)

redraider08 12-06-2012 10:29 AM

Drain Plug Location
 
2 Attachment(s)
Hey guys, i have a 2000 X-star with the 310 inmar and am not real sure where the drain plugs are. Below are a couple of pictures i took pointing to what i think may be the drain plug, but it looks like there is some type of sensor at the location on the portside. Thanks for the help!

mwg 12-06-2012 12:20 PM

I have an LTR which is the same block; I remove the knock sensor on the starboard side & a brass plug in a similar position on the port side to drain the block. In the first picture, the knock sensor is located directly behind the starter below the plug wires.

dfmaus 12-06-2012 12:58 PM

1 Attachment(s)
same for me - I drew in an arrow to be perfectly clear. This is the knock sensor


Quote:

Originally Posted by mwg (Post 894424)
I have an LTR which is the same block; I remove the knock sensor on the starboard side & a brass plug in a similar position on the port side to drain the block. In the first picture, the knock sensor is located directly behind the starter below the plug wires.


carlsonwa 12-06-2012 01:12 PM

Quote:

Originally Posted by dfmaus (Post 894436)
same for me - I drew in an arrow to be perfectly clear. This is the knock sensor

There should be a plain brass plug on the opposite side then as well.

redraider08 12-06-2012 02:50 PM

Thanks for the help, is there any plugs on the manafold that need to be drained? Also, what is the sensor that i had an arrow pointed to in the origonal post? Thanks!

mwg 12-06-2012 04:43 PM

Quote:

Originally Posted by redraider08 (Post 894456)
Thanks for the help, is there any plugs on the manafold that need to be drained? Also, what is the sensor that i had an arrow pointed to in the origonal post? Thanks!

Temperature sensor (?)..

If I recall correctly (still too early for me to winterize :D), to drain the manifolds disconnect the hoses where the join, there should be a hose type connector.

bsloop 12-07-2012 10:03 AM

Quote:

Originally Posted by redraider08 (Post 894456)
is there any plugs on the manafold that need to be drained?

Quote:

Originally Posted by mwg (Post 894492)
Temperature sensor (?)..

If I recall correctly (still too early for me to winterize :D), to drain the manifolds disconnect the hoses where the join, there should be a hose type connector.

Depending on which end of the exhaust manifold is lower, either disconnect the exhaust manifold hoses or remove the plug on the opposite end with a 1/2" socket drive.

To be anal, before reinstalling plugs, I usually take a drive up and down the block once that has hills to shake any other antifreeze out.
I drain, antifreeze, drain, then store. By draining water first, I am sure the AF is not diluted as it passes through.

CC2MC 12-07-2012 10:49 AM

I believe he is correct is saying it is a temp sensor as it is right along side the spark plugs. Unplug the knock sensor first then either a 7/16" or 7/8" socket should fit right on it, provided it is the same as my boat. The manifold should have a plug on each end, which in your boat should be forward, if I am not mistaken. It looks like there may be an L connector with a hose coming out of it. See if that hose is connected to another hose from the other manifold. If so, you should be able to unscrew them in the middle and drain the manifold into the bilge. My boat is a direct drive so the engine is turned the opposite way.


All times are GMT -4. The time now is 02:51 AM.