TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   Engine / Drive Train (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=24)
-   -   'Check Engine' under power (http://www.mastercraft.com/teamtalk/showthread.php?t=50196)

benvickers38 08-13-2012 01:22 AM

'Check Engine' under power
 
Help! My stereo cuts off and the "CHK ENG" warning comes on when I'm at higher than idle power. What could that be?

2007 X-Star SS, 6.0L Crusader, WetSounds tower speakers w/ eBay-bought amp.

Any thoughts? Thanks.

76S&S 08-13-2012 09:12 AM

Sounds like a weak battery; give it a good charge and see if that is it.

I'm assuming that all other gauges check out ok.

JimN 08-13-2012 09:55 AM

Quote:

Originally Posted by benvickers38 (Post 867697)
Help! My stereo cuts off and the "CHK ENG" warning comes on when I'm at higher than idle power. What could that be?

2007 X-Star SS, 6.0L Crusader, WetSounds tower speakers w/ eBay-bought amp.

Any thoughts? Thanks.

Since it only happens when you go faster than idle, I would look at connections. Who installed the amp and how were the cables connected? Was it connected directly to the battery? If not, you need to do that. Proper termination of all cables is critical. It could be a bad connection at the battery, bad alternator, etc- as long as it cranks when you need it to, I don't suspect the battery.

willyt 08-13-2012 09:58 AM

temperature?
oil pressure?
volts?
kicking you down into limp mode?

need more information


All times are GMT -4. The time now is 01:09 PM.