TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   Electrical (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=23)
-   -   Fuel Sender 101 (http://www.mastercraft.com/teamtalk/showthread.php?t=48823)

mtajpa 06-27-2012 03:10 AM

Fuel Sender 101
 
10 Attachment(s)
My fuel gauge on my 99 Maristar 230 quit working so I decided to post my method for testing and replacement. When the key is turned on the gauge pegs and then returns to the empty position. This is with the key on and appx half a tank of fuel.
http://www.mastercraft.com/teamtalk/...1&d=1340839446

The sending unit I have is a 2 wire unit. It is basically an adjustable resistor that is activated by the fuel level. Some have a float others has an electronic sender. The fuel position on the guage should read full when the sender is at 33 ohms and empty when sender is at 240 ohms. Half s tank will be indicated at appx 100 ohms. The factory sender had adjustable trim pots to fine tune the sender to the gauge.

I am not 100%sure but I think this procedure will work with the 3 wire sender also as the 3 wire unit has a positive connection also.
http://www.mastercraft.com/teamtalk/...1&d=1340840067

First we will disconnect the sender from the harness. Then I got some resistors from Radio Shack 2 ea 100 ohm and a 33 ohm. I placed these in series to test the gauge. Should read 233 but this is close enough. Kind of a cheapo meter.

http://www.mastercraft.com/teamtalk/...1&d=1340840067

Next I connected some test leads to the harness leading to the fuel gauge. This is the part that was previously disconnected. One side goes to the sender and the other to the gauge.
http://www.mastercraft.com/teamtalk/...1&d=1340840067

At the other end of the test leads I connected the resistors and observed the gauge. With the key on I then placed the test lead across the 33 ohm resistor and the gauge reads full.
http://www.mastercraft.com/teamtalk/...1&d=1340840067
Then moved the leads to the 100 ohm resistor. This gave me a half tank reading.
http://www.mastercraft.com/teamtalk/...1&d=1340840067

Then the last test with the resistors is using the 2 100’s and the 33 in series for a total of 233 ohms. This gave me an empty reading.
http://www.mastercraft.com/teamtalk/...1&d=1340840067
This verifies the gauge operation to be correct for the 33-240 ohm sender.

I then moved to the sender to see what kind of ohm reading I was getting. It was reading 320 ohm across the black(gnd) to Pink (sender) leads. Since the sender should only read 240 ohms when empty then this means the sender is faulty.
http://www.mastercraft.com/teamtalk/...1&d=1340840067

For this next step be sure to have your ignition off and disconnect or turn OFF you batteries. Make sure you have a fire extinguisher at the ready.

I then removed the sender by removing the 5 screws and pulling the sender up and out of the tank. Have a rag handy to catch any fuel leaking off the sender.

Once the sender is removed the fuel tank the tank will be exposed to the elements place a rag or something to keep things from falling into it.

My sender looks like this it is 10 inches in length.
http://www.mastercraft.com/teamtalk/...1&d=1340840067

My tank is a 65 gallon with a depth of 11 inches at the sender location. If your are not sure of your depth then get a wooden yardstick and insert it into the tank at the sender hole. Your sender should be 1 inch less than the tank depth.

I ordered a replacement from SkiDim. It isn’t exactly the same but will work as electrically it has the same value of 33 ohm when full and 240 ohms when empty. The one I took out did not have an external float.
http://www.mastercraft.com/teamtalk/...1&d=1340840067

TO BE CONTINUED ON NEXT THREAD WITH MORE PICTURES

disreguard pictures below they are the same as the ones used between text couldn't figure ho to get rid of them.

mtajpa 06-27-2012 03:25 AM

Fuel Sender 101 Continued
 
10 Attachment(s)
I then took the new unit and tested it WITH THE OHM METER prior to installing it. With the float all the way up it was reading 33 ohms

http://www.mastercraft.com/teamtalk/...1&d=1340840871

In the middle it was reading 100 ohms

http://www.mastercraft.com/teamtalk/...1&d=1340840871

At the bottom it was reading 240 ohms.

http://www.mastercraft.com/teamtalk/...1&d=1340840871
I then installed the sender into the tank to find the proper alignment before placing the gasket on. It only fits in one way.

http://www.mastercraft.com/teamtalk/...1&d=1340840871

The sender then was removed and the gasket and new screws were installed on to the sender. Install the sender back into the tank with the same orientation as before. Be sure to use the correct screws as the kit comes with 2 different thread sizes.

Gently tighten these screws in a criss cross pattern tighten until you see the gasket start to bulge just a little then stop. Overtightening will destroy the gasket and possibly damage the tank.

Now that the sender is installed you will have to connect the wires into the old senders harness. Just cut the old wires from the sender and splice them on to the new one. Be sure to use a method that will not allow any moisture to get into the connections.

http://www.mastercraft.com/teamtalk/...1&d=1340840871
http://www.mastercraft.com/teamtalk/...1&d=1340840871
Think that your done well not just yet One more thing to check before plugging in the sender.

You want to check that you have a good ground connection at the sender harness. Using an ohm meter connect one of the leads from the black wire on the boat side of the sender harness. Connect the other side to a good ground (I used the negative side of the battery as it was close). You should get a reading of 0.0 ohms if you connection is perfect Mine read 1.0 ohms however the meter I was using had 0.5 ohms of lead resistance. 0.5 ohms is acceptable to me.

http://www.mastercraft.com/teamtalk/...1&d=1340840871
To test the lead resistance simply connect you ohm meter leads together your meter will read 0.00 if your leads are perfect if not subtract this reading from all your readings if you want more accuracy.

http://www.mastercraft.com/teamtalk/...1&d=1340840871

Now remove the meter and plug the harness into the sender and dress up the wiring.

http://www.mastercraft.com/teamtalk/...1&d=1340840871

Turn on or reconnect your battery. Then turn on your key and you should see what your fuel level is.

http://www.mastercraft.com/teamtalk/...1&d=1340840871

Looks like I better get me some fuel. Its below the Ĺ level donít want to have to read the FUEL PUMP 101 thread.

Hope this helps.

Pictures below are same ones used between text. disreguard

bturner2 06-27-2012 07:32 AM

Very detailed and very good information. Good post, wish I could see the pictures you included. For some reason they're not showing up for me.

Voodoo 06-27-2012 07:37 AM

Ditto, cannot see pics. Awesome data.
Voodoo

76S&S 06-27-2012 08:32 AM

No pics here either.

mtajpa 06-27-2012 08:02 PM

Finally the pictures are up.
 
Sorry had the pictures linked to my computer so I could see them but nobody else. I logged off and they are now appearing. Hope this works. Also for some reason the pictures are all together at the end of the thread. OH well at least there pictures now. Enjoy

tim79mc 06-27-2012 10:49 PM

nice post - glad you're back up and running. I had a problem with fuel gauge reading erratically - turned out I drilled into the sender wires when replacing the rub rail. oops.

SkiDaddy 06-28-2012 06:50 AM

That's the way to do it! Great post!

Lumbergh 06-28-2012 11:38 AM

Awesome.

This should be a sticky.

Nice work and thanks for taking the time do do this!

curtish 07-01-2012 04:53 PM

Nice! Need to do some testing as our gauge only reads 5-7 8ths full when it is actually full. Makes for lots of fun at the gas station. :mad:


All times are GMT -4. The time now is 10:16 PM.