TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   Electrical (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=23)
-   -   Gauge Problem, Gauges not working, 2002 X-star (http://www.mastercraft.com/teamtalk/showthread.php?t=43832)

Frazby010 09-11-2011 08:52 PM

Gauge Problem, Gauges not working, 2002 X-star
 
I need some helping figuring out what is up with my gauges on my 2002 X-star. I bought the boat about 3 months ago knowing it needed a few things fixed, the fuel gauge was one of those. It did not work 90% of the time. After a little research I decided the fuel gauge sensor could be the culprit, so I replaced the fuel gauge sensor about 2 weeks ago. It seemed to work fine for about a 4 or 5 days then it went back to it's old habits of only working when it wanted to...to make matters worse today I had the boat out and Perfect Pass suddenly quit working. I cut the boat off and when I cut it back on all of the gauges quit working. (fuel, rpm, oil pressure, volts, etc.) The only one that worked was the depth finder. We had a big rain a few days ago and even though the boat was covered on a lift it got a lot of water in it. Is it possible the rain shorted something out? I read on another post something about a MDC box? Blown fuses? Any help in figuring out what the problem is would be greatly appreciated.

agarabaghi 09-12-2011 03:35 PM

Let it dry out completely. Sometimes that will fix it.

If not start unplugging each guage one at a time and seeing if the others come back to life. My oil gauge went bad, and it took out all the other ones.

Frazby010 09-16-2011 12:08 PM

Agarabaghi, A friend and I took all the seats out and put a fan inside the compartment with the battery this past Tuesday. I cranked it Wednesday and perfect pass was the only thing that came back to life. :( I am going to go down this afternoon and see if there are any changes. Where do I unplug the gauges at? I am going to try that next....

possumlover82 09-16-2011 03:06 PM

I am having a similar issue, My tach has never worked. Now the only gauges that work are the speedo, perfect pass, fuel gage, depth finder. I bought a new Black box ECU and put it and that didn't change anything. So my voltmeter, temp, and tach don't work. none of the gauges go through the cycle test when you first apply power either. You can hear (what i assume to be the servos) running like they would when the gauges go through the test but the needles don't really move. They may flicker. I haven't tried unplugging them one by one though.


All times are GMT -4. The time now is 06:34 AM.