TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   General Discussion (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=6)
-   -   Engine Temp on PS 190 (http://www.mastercraft.com/teamtalk/showthread.php?t=616)

acurtis_ttu 09-08-2004 02:48 PM

Engine Temp on PS 190
 
What temperature should my 96 PS 190 be running at? As I remember it used to run aroudn 140 now its running a little hotter, near 150-160. I have anohter friends baot, same baot but a 95, his runs near 135-140. This seems very cool. Is it correct??

east tx skier 09-08-2004 02:52 PM

160 is right about normal. Some boats run a little cooler. If it's running a bit hotter, when did you last change the impeller?

André 09-08-2004 02:53 PM

If you have the TBI engines,both boats should be running aroud 160.
The LT 1 should be around that too.(I think).
Why the sudden raise on the gauge?Impeller?

André 09-08-2004 02:56 PM

Dawm fast typing Doug...LOL

east tx skier 09-08-2004 03:04 PM

My father in law's boat (308 hp TBI) was running at about 150 on Saturday, but at 200 on Sunday. We towed it to the launch and I pulled a rather chewed up impeller out of the pump. After a little back flushing, I found the rest of it (whew).

Can't say enough times what a good idea it is to just change these things out every spring whether you think you need to or not.

/just ordered mine for next year this morning.

André 09-08-2004 03:08 PM

Man,you're getting very good !

east tx skier 09-08-2004 03:22 PM

So easy to do, but so impressive to people who don't spend quite so much time reading about this stuff. Learned more from this site that I'd have ever thought possible.

acurtis_ttu 09-08-2004 03:32 PM

i changed the impeller, and now it runs hotter than before. about 10 degrees or so (150-160) I've flushed all the lines, cleaned the transmision screens, and still there is fluctuations in the cooling. The strangest thing is that when you turn the motor off, the temp skyrockets to 180-190. I'm thinking thermostat?? It will stay at 140 when first idling, then jump to 150-160 when running, then after letting off the throttle jumps to 165-170 then back to 150-160 w/ occasional dips to 140 when in idle.

André 09-08-2004 03:50 PM

Mine is a 94 TBI and on hot summer day when i stop the engine ,temp will rise SLOWLY to 180 MAX in about 5 minutes.On restart(Always fresh impeller) it will immediately go down LOWER then it's normal oper. temp. of 158 at about 140 then will get back to 158 after we get back skiing.
From all i have read those numbers seems to be normal for a tbi of this generation.
Whenever my engine is running ,temp will never go higher then 158.
Was your impeller damaged?
Did you find all of the pieces?

acurtis_ttu 09-08-2004 04:10 PM

my impeller looked fine, but i replaced it anyway. I just can't think that that much fluctuation in temp is good for the motor. 140-180. My engine will go into "limp" mode around 185-190. I did clean some junk off the transmission screen. It all started when I broke a belt, but the temp. never got over 180, when the belt broke. Something is different....my temp guage never used to vary this much. it would stay around 140 all day.


All times are GMT -4. The time now is 07:02 AM.


2018