TeamTalk

TeamTalk (http://www.mastercraft.com/teamtalk/index.php)
-   Engine / Drive Train (http://www.mastercraft.com/teamtalk/forumdisplay.php?f=24)
-   -   alarm while idling (http://www.mastercraft.com/teamtalk/showthread.php?t=57774)

KWSC 10-09-2013 02:26 PM

alarm while idling
 
hi,

Recently I have been getting an alarm after extended idling or trolling - say over 1min. The alarm sounds but the check engine light doesn't come on (the light does work). Does anyone know what this could be?

I am pretty sure that it is not overtemp as I have had that before when my impeller was going and the check light would go on and I could see that the engine temp was too high. My best guess is that it is a low oil pressure alarm since this only happens when the engine is warm and the gauge does read low. If I troll at a faster rate to increase oil pressure the alarm won't go on.

Has anyone else had this? What has fixed it? Is the engine losing oil pressure or is my sensor going?

Thx,

Paul

bjen 10-09-2013 02:59 PM

low voltage I bet, what is your battery/altenator setup like?

I think the low voltage alarm stays on for 2 minutes or something when it is low

ricford 10-09-2013 04:01 PM

It's a special Master Craft alarm that senses when you are fishing in a ski boat.

KWSC 10-09-2013 04:22 PM

I have a totally stock battery/alternator setup. The battery is older so that could be a reason although it has never given us grief - starts up everytime. I would also expect to get this alarm after the boat hasn't been run for awhile and the battery is more depleted but this isn't the case.

KWSC 10-11-2013 12:01 PM

Anybody have any more ideas other than voltage. Can this alarm be read?

curver900 10-11-2013 12:51 PM

what is the oil pressue when idling? there are 2 sensors one for the gauge (I just replace mine) and one for the ECU that triggers the alarm. I think you already answered your question if you spead up the pressure goes up the alarm goes off... start there... get a hand held pressure gauge to double check it... put in new ecu pressure sensor if the alarm goes off after that then it is probably a bigger problem like the oil pump... but highly unlikely unless run low on oil....

KWSC 10-11-2013 01:26 PM

The oil pressure is quite low while idling (when warm). When the boat is at speed the pressure is right up. Oil level is good. I'll see if I can get a gauge and I will try reving the boat when the alarm comes on to see if it will go off. Typically we just shut the boat off and restart to clear the alarm.

thx

KWSC 10-14-2013 10:46 PM

So I was on the water on Saturday and it was alarming again - really seems like its the oil pressure. Is the oil pump probably to go (and only at idle)? Or is it most likely the sensors? How do I check oil pressure with a manual gauge? Any tips on checking the sensors? I'd rather confirm a few things before I start wildly replacing parts.

2010Prostar197 10-15-2013 01:18 AM

What is the pressure when you say it's "low" and triggering the alarm???

And what is the idle pressure a few minutes after starting a cold engine? (Sitting over night)

And also what is the pressure hot and running like pulling a skier?

KWSC 10-15-2013 02:24 PM

my gauge pressures are approx: cold idle 30-40psi, at speed 40-60psi, fully up to temp idle 1-3psi. Oil is 30hrs old 15w-40.

Looking online for low oil pressure at idle alarms points me to the direction of replacing the oil pressure sender and not the oil pressure switch.


All times are GMT -4. The time now is 02:32 AM.