Go Back   TeamTalk > View Profile

JimmyDean JimmyDean is offline

TT Newbie

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. FoggyNogginz
    05-24-2016 12:30 AM
    FoggyNogginz
    Sorry to hear of your troubles with the dealers. I think many of the issues that we both experienced are isolated to a select few years and models which makes it more difficult to troubleshoot. As for max temp, my Ilmor 5.7 has a 170 degree thermostat and the alarm will go off around 200 if I remember correctly. Close cooled systems can get as high as 240 before they alarm. You should not be seeing 210 in my opinion.

    As for bumping the RPMs at idle when you first put it in the water, this helps to prime the pump on the 2011-2013 models with the dripless shaft seal. These boats basically drain the manifolds each time that you pull them out of the water, so a little priming is necessary if you were going to otherwise idle for several minutes at the dock or no wake zone after initially putting the boat in the water. Of course, all of this assumes that the tstat, impeller, circulator, and strainer are all working properly.

    Good luck!

About Me

  • About JimmyDean
    City
    Overland Park
    State
    Ks
    Location
    Midwest
    Gender
    male
    Team MasterCraft Member
    no
    Boat Owned
    Mastercraft, X15, 2011, Ilmor
    Occupation
    Hospital Sales

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 05-21-2016 11:12 PM
  • Join Date: 05-16-2012
  • Referrals: 0

Friends

Showing Friends 1 to 2 of 2

All times are GMT -4. The time now is 12:18 PM.