PDA

View Full Version : Check Engine Light


h2oskier
06-05-2006, 09:03 PM
I have an '03 209 with the MCX engine and this year is the first year I have experienced this problem.

The check engine light comes on when I get above 25 mph or so. The light will not go off until I turn the engine off and it will stay off even when I restart and stay at a low speed.

All gauges, temp, volt meter, oil press read normal.

Any suggestions?

Thanks,
Bryan

erkoehler
06-05-2006, 09:08 PM
Have you checked the oil and trans fluid levels?

JimN
06-05-2006, 09:19 PM
Check the impeller and oil cooler. You may see a relatively normal temperature but if the ECM sees something it doesn't like, you'll see a check engine light but nothing on the gauge. There are two different sensors.

PendO
06-05-2006, 10:41 PM
Check to make sure that the Knock Sensor is plugged in ... that is about the speed/rpms when the ECM starts looking for a signal from the knock sensor on the engine block.

If you are not far from a dealer see if they can plug the code reader into the ECM and pull the codes.

I have an '03 209 with the MCX engine and this year is the first year I have experienced this problem.

The check engine light comes on when I get above 25 mph or so. The light will not go off until I turn the engine off and it will stay off even when I restart and stay at a low speed.

All gauges, temp, volt meter, oil press read normal.

Any suggestions?

Thanks,
Bryan

h2oskier
06-06-2006, 05:35 PM
Thanks PendO,

It was the knock sensor. It was unpluged when the dealer winterized the boat and not pluged in when they finished.

Thanks again!!

PendO
06-06-2006, 05:36 PM
Thanks PendO,

It was the knock sensor. It was unpluged when the dealer winterized the boat and not pluged in when they finished.

Thanks again!!

no problem man - glad it was that easy!