PDA

View Full Version : Engine Overheating : Running HOT!


Tennessee J
06-05-2006, 12:23 PM
Engine is overheating. Yesterday I noticed the temp was up to 200 and trying to climb. I only noticed because the engine cut itself back as we were cruising. (I guess the it governs itself to cut off if getting too hot) I pulled back on the throttle, and the temp dropped to normal within about 3-4 minutes. We checked for any signs possible, but did not notice anything out of the ordinary. Besides this, the engine sounds fine. Any suggestions?

vogelm1
06-05-2006, 12:31 PM
Assuming you checked the typical stuff (oil/transmission level, impeller, tranny oil cooler)? The tranny cooler is an easy one to forget...if you remove the lower hose, or one on right side of the cooler, there is a screen in there that gets plugged with weeds, debris, etc. If it's not that and your impeller is good, I would say you need to look at the thermostat next.

sanjuan23
06-05-2006, 12:33 PM
Check The Impeller And Water Intake For Grass Etc. Of Course If You Have A Closed Cooling System Whole Different Can Of Worms.

G-man
06-05-2006, 12:33 PM
My bet is on the impeller not getting changed in the spring

Tennessee J
06-05-2006, 12:55 PM
Thanks for the suggestions, I'll follow them up this week and hopefully be good to go by the weekend. - J

PerryBpilot
06-06-2006, 09:37 PM
Look at my thread cooling problems....overheating.
Several guys had great suggestions and helped me solve my problem!!!!
Check the transmission cooler the previous posts were not exaggerating at how easily it clogs and mine was actually pretty easy to get to.

GOOD LUCK!!!