PDA

View Full Version : Knock, Knock....


Faded & X9-Rated
05-29-2006, 11:01 PM
That's what my MCX 350 kept askin me today...

I put the X9 in the water today after a 2 week break.. only to hear the motor knockin like CRAZY!!!!! It sounds really bad.. my brother listened to it.. looked at me & said "We had a motor at work sound just like this.. & had to be replaced..." Taking it to the local MasterCraft dealer this week.. I'll keep you posted :noface:

Steve

6ballsisall
05-29-2006, 11:02 PM
That's what my MCX 350 kept askin me today...

I put the X9 in the water today after a 2 week break.. only to hear the motor knockin like CRAZY!!!!! It sounds really bad.. my brother listened to it.. looked at me & said "We had a motor at work sound just like this.. & had to be replaced..." Taking it to the local MasterCraft dealer this week.. I'll keep you posted :noface:

Steve


Eeks! Not good! Did she have oil in her?

skitilldark
05-29-2006, 11:12 PM
Well, I thought my disasters at the lake yesterday were bad. Yikes. Actually my X-9 started knocking after a prolonged 3500 rpm run a couple of years ago. Found fuel in the oil. After changing to a slightly hotter thermostat and replacing all the injector nozzles...problem solved. Turns out one injector nozzle was leaking after power shutdown(when there is still significant pressure in the fuel rail). It was squirting fuel into an unfiring cylinder and would eventually make its way into the oil pan. Eventually it would thin the oil enough to collapse a lifter. Don't know if this is your problem, but it sure scared the heck out of me!

jimmer2880
05-30-2006, 07:44 AM
Holy Cr@p... How long did it take you to figure that one out?

skitilldark
05-30-2006, 10:59 AM
Holy Cr@p... How long did it take you to figure that one out?

If you're referring to my problem, it took one entire ski season. the most bizarre thing was at first, the boat kept GAINING oil volume. Well, unless I don't understand internal combustion engines, I'm almost positive they can't manufacture oil. But everytime I checked, I would find a quarter of a quart extra, then a half a quart, etc. I called MasterCraft, I called Indmar, I called that talk show on the radio with the car guys. They were actually the ones who put me onto the injector nozzles. It made perfect sense because I knew gas was in the oil. You could see the color change, but the engine was running perfectly fine(no rich symptoms or black smoke, etc.) So it had to be happening while the boat was not running. Anyway, glad its over.
(Sorry for the threadjack, by the way)

Faded & X9-Rated
05-30-2006, 11:05 AM
Eeks! Not good! Did she have oil in her?

Yeah, Oil was fine, plugs are fine.. This blows!