PDA

View Full Version : Clarion system issues


krseitz
05-05-2006, 01:40 PM
This spring, I brought my 2004 X9 out of winterization and had an issue with the sound system. The tower speakers and the sub were working but the 4 speakers in the boat weren't. Other then pulling the battery for storage, nothing had happened to cause an issue. :confused:

After hours of digging through wires, fuses, changing amp settings, cursing, etc., I contacted Greg Clower at Mastercraft and he sent me a bulletin that solved my issue. Cudos to Greg and Mastercraft for providing GREAT support. :woohoo:

I attached the bulletin in case any of you have the same issue.

#47of100TeamMC
05-05-2006, 02:22 PM
I wish I had tower speakers...

PendO
05-05-2006, 02:29 PM
This is a common issue that deals with programming the deck ... we have the same issue every year with our 04 X-star, the dealer gave us a sheet of instructions to follow ... thanks for the link.

This spring, I brought my 2004 X9 out of winterization and had an issue with the sound system. The tower speakers and the sub were working but the 4 speakers in the boat weren't. Other then pulling the battery for storage, nothing had happened to cause an issue. :confused:

After hours of digging through wires, fuses, changing amp settings, cursing, etc., I contacted Greg Clower at Mastercraft and he sent me a bulletin that solved my issue. Cudos to Greg and Mastercraft for providing GREAT support. :woohoo:

I attached the bulletin in case any of you have the same issue.

Ric
05-05-2006, 02:37 PM
good to hear you fixed it, that bulletin is found at mymastercraft.com as well