PDA

View Full Version : Help-Brakes won't disengage!


Grayfox
04-29-2006, 09:32 PM
Has anyone had this problem and if so can you offer some assistance? I have a new 2006 x-star, the braking system is electric (not surge). I made a left turn into the park where we normally launch our boat, immediately the brakes engaged and would not release. Engaged to the point that my Tahoe was struggling to pull the boat even ten feet. The brakes are still engage and won't release. My dealer is almost forty miles away, what can I do? I have check the brake fluid level and it is fine. I have no answers, please help.

Larryp
04-29-2006, 09:51 PM
are you using the five pin connector

Workin' 4 Toys
04-29-2006, 10:36 PM
are you using the five pin connector
I would like to ask the same.
And it made it home 40 miles? Then to the ramp, but at the launch is locked up?

east tx skier
04-29-2006, 11:30 PM
Is this a MC trailer? Are the new trailers using electric brakes?

PendO
04-30-2006, 12:08 AM
Its a good thing you had a laptop with WiFi at the launch ... seriously though, when you hook up to your Tahoe you had two black cables with clarger clips, and then a smaller diameter bare metal cable with and "S" hook on it, I would venture to say that when you made the left hand turn the thin cable got pulled tight and locked up the brakes (like it is supposed to do if your trailer comes off the hitch ball)... perhaps it did not have enough slack ... and if you pulled it tight (with a lot of force) it may not release back to normal ... make sense?

If it was the wrong connector I think the problem would not be noticable going forward, only in reverse

Has anyone had this problem and if so can you offer some assistance? I have a new 2006 x-star, the braking system is electric (not surge). I made a left turn into the park where we normally launch our boat, immediately the brakes engaged and would not release. Engaged to the point that my Tahoe was struggling to pull the boat even ten feet. The brakes are still engage and won't release. My dealer is almost forty miles away, what can I do? I have check the brake fluid level and it is fine. I have no answers, please help.

PendO
04-30-2006, 12:20 AM
here is a little better pic of what might have gotten pulled tight on your turn and locked up the brakes.

Grayfox
05-01-2006, 08:37 AM
I was thinking it was the wire connected to the trailer also but I am not sure. Thanks for your comments, I was at work this weekend and now I am going to look into your suggestions.

Ric
05-01-2006, 10:30 AM
if only pendo had a photo gallery........

my 05 brakes are surge, but they hung up on me one day and after some *****ing I took it off the truck looked it all over and APPARANTLY the brake line that runs thru the folding tongue area, got kinked when we hitched up.....

I watch for that each time I hook up now, but what's aggrivating is that now my trailer brakes squeal like a pig each time the brakes engage :noface: