PDA

View Full Version : Shower Quit Working


teddy
04-26-2006, 11:56 PM
I have a Heatercraft Shower in my boat. It worked for part of the summer and then quit. The breaker flicked off a couple of times before it stopped working completly. Any suggestions on troubleshooting the problem would be appreciated.

erkoehler
04-27-2006, 12:06 AM
I would start with cleaning out the filter screens, you may have clogged one up which is causing to much pressure. I have had that cause the breaker to flip. Possibly check your wiring connections if you haven't done so....

teddy
04-27-2006, 12:30 AM
Where are the filter screens?

erkoehler
04-27-2006, 12:32 AM
Unscrew the hot and cold supply lines from the mixing control, and you should see them.

teddy
04-27-2006, 12:45 AM
I'll try that this weekend. The boat is kept at the lake so I can't try it today.

erkoehler
04-27-2006, 12:47 AM
Otherwise, if you have a air compressor available, you can try to blow out the lines.

teddy
04-30-2006, 11:40 PM
I tested the wires to the pump and had juice to the pump. No action at the pump when I switch it on. I have water to the pump that flows by itself when I disconnect the line at the pump coming from the mixing box. I'm thinking new pump. Any comments on my analysis and if you agree where I might find a pump.

erkoehler
04-30-2006, 11:43 PM
Ebay for the pump...

teddy
05-23-2006, 12:34 AM
I picked up a new pump on Ebay for $79.00 with shipping. Arrived a couple of days ago and installed it this past weekend. My old pump was a 1.3 gpm and the new one is 2.3 gpm. A nice improvement. The install was straight forward and it is nice to throw some hot water in the wetsuit again. Thanks for the suggestion.