PDA

View Full Version : water pump now drippomg


stevek
04-16-2006, 02:33 AM
:steering: Ok now I just realized that my water pump on my 89 prostar has a little drip coming out of it now and before I go buy a new one is there a way to rebuild this one like I just found out on the alternator? It wasn't doing this when I put it away last year and I just put a new impeller in it. Any suggestions?

jackpita
04-16-2006, 08:37 AM
Same thing happened to me. SEAL R\W PUMP JOHNSON (#0603)
18 bucks at Ski Dim. Easy to replace.

http://www.skidim.com/prodinfo.asp?number=68-5004

bigmac
04-16-2006, 09:10 AM
Same thing happened to me. SEAL R\W PUMP JOHNSON (#0603)
18 bucks at Ski Dim. Easy to replace.

http://www.skidim.com/prodinfo.asp?number=68-5004

Here's a key statement from SkiDIM that I found interesting:
http://www.skidim.com/images/68-5004.jpg
If your pump is leaking from the back side it is normally caused by this seal being worn or deformed. Be carefull when removing or installing your impeller and dont let the impeller c0ck to one side and try to force it in. If you put lateral pressure on the impeller shaft it may distort this seal causing a leak.

sprink
05-07-2006, 04:01 PM
I searched water pump and found this thread. This is exactly what happened to me. I replaced the impeller last weekend and took the boat out today. Everything was working great. No leaks from the impeller but noticed water in the bilge. Tracked it down to the water pump. I thought maybe the impeller had something to do with it and was hoping I would not need a new pump (only 93 hours on the engine). Looks like the seal could be the problem. is that the same seal for an LTR? Did changing the seal solve your problems?