PDA

View Full Version : 2009 X80 Rebuild after sinking!


aussiex80
07-21-2014, 06:24 PM
I haven't posted anything for a while however just finished the X80 rebuild after it sank off Sovereign Island, Gold Coast - Australia. A big thanks goes to Scott Birdsall from MasterCraft Services in Australia and MasterCraft in the USA. The new 6.2L OPS Ilmors fitted straight in replacing the 6.0L Crusaders. Only a couple of engine mount holes had to be drilled and tapped as I wanted to use the new engine mounts. Also had to mount the throttle position sensors as the X80 had throttle cables. All exhausts, harness and cooling hoses fitted easily. We plugged the 2009 boat harness to the 2104 Ilmor harness and every gauge, engine sync, perfect pass and computer worked perfectly. Scotty pre-delivered the engines, inspected the install, ran them up on the trailer and even came for the first sea trial. Thanks Mate. :D:D:D

soacj
07-21-2014, 08:24 PM
That pair of Ilmor 6.2's look awesome in there...I know it's been said already, but holy spark plug access!

scott023
07-21-2014, 10:26 PM
Those look nasty in there. Love it. How about a sound clip of them?

thatsmrmastercraft
07-21-2014, 11:52 PM
Tight fit but it looks incredible. Would love to hear them as well. :toast:

DemolitionMan
07-22-2014, 10:24 AM
That looks great!

BrooksfamX2
07-22-2014, 10:54 AM
Very nice........:)

TNX5TY
07-22-2014, 11:24 AM
Holy Smokes!!

cwarndahl
07-22-2014, 11:31 AM
OH man that is awesome!

McDye
07-23-2014, 06:21 AM
WOW...lost for words

Burbon66
07-23-2014, 07:44 AM
Looks very cool, yep running vid would be ace.