PDA

View Full Version : gauges not workin (volt, oil, engine)


Will Pope 77
06-04-2014, 10:26 PM
Where would the ground wire be located or Mac box what ever that is. Lights work so there is power. Any suggestions?

Jeff d
06-04-2014, 10:34 PM
Does the engine start? If not your kill switch lanyard may be pulled or the switch itself is defective

The box is called the MDC. It should have an 18 pin connector going into the MDC. You should have ground on pin 2C (black wire), constant +12 volts on pin 1A (red, maybe orange) and ignition switched +12 volts on pin 1B (purple wire) .

Jeff d
06-04-2014, 10:55 PM
Here's a troubleshooting guide that's probably close enough to what you have to be beneficial:
http://www.bakesonline.com/images/MediaLibrary/MedallionII_Troubleshoot.pdf

Also, the most common failure is due to water from the speedometer pitot freezing inside the mdc over the winter. Most forget to blow it out/drain it as part of winterization. It can crack open the case and allow water to contact the electronics. Look for physical damage when inspecting the MDC.

Jeff d
06-04-2014, 11:01 PM
Btw the gauge back lights are powered independently of the MDC. Back lights working is not an indication of a functioning MDC. In fact, you can remove it completely and the back lights on the gauges will still work if you turn the Nav lights on.

Will Pope 77
06-05-2014, 12:20 AM
Thanks for the info Jeff.

Will Pope 77
06-05-2014, 12:24 AM
Jeff what does mdc mean. Don't want to sound stupid but...

Jeff d
06-05-2014, 12:29 AM
Marine Data Controller. It's a Medallion product just like your gauges.

Topp dawg
06-05-2014, 05:06 PM
I had this same issue last year and it turns out I had to replace all my gauges. I mailed my mmdc to medallion and they tested it for free for me and said it was good. I bought new gauges and everything now works fine. Cost me about 200 bucks for gauges.