PDA

View Full Version : Ballast Pump Timers


imyourmaster
12-09-2013, 06:40 PM
Can anyone shed light on the timer fuction of the ballast pumps? I have a '08 x-2... my ballast pumps do not seem to turn off when filling the tanks. They keep pumping after the tanks have filled and I can see water spewing out from the thru hull fittings. Same happens on emptying the tanks. I can hear the pumps running even after the tanks have emptied. Is this normal? I'm concerned that I might burn out the pumps and destroy the impellers especially on the empty cycle.

snork
12-09-2013, 07:11 PM
you must have one of the reprogramed timer
thanks for the reminder I need to send mine off for the reprogram'n

Dalilamba
12-09-2013, 09:39 PM
Deon, try disconnecting the battery for a couple minutes and that might reset your timers. It worked on my 07 X2 when I had it.

imyourmaster
12-10-2013, 08:05 AM
Deon, try disconnecting the battery for a couple minutes and that might reset your timers. It worked on my 07 X2 when I had it.


Will give it a try for sure. I disconnected the batteries last weekend so I should be able to test the next time I take it out.

JRW160
12-10-2013, 10:09 AM
This post covers how to change the run time on them. I think the 2007 timers maxed out at 5 or 6 minutes and 2008 and up the timers max out at 20min.
http://www.mastercraft.com/teamtalk/showpost.php?p=523264&postcount=8

My boat doesn't have timers. I just run them until I hear the sound change. If you have the green impellers, they can be run dry for a while before it does any damage.

Dalilamba
12-10-2013, 04:46 PM
Yes the 07 timers maxed out at 6 minutes