PDA

View Full Version : Rough Start Indmar LTR.


swatguy
09-09-2013, 01:33 AM
Well I felt was running a little rich lately and was having a small hot start issue on 100 degree days after turning of the engine while swapping riders in the. it would start up but i would have to kick up the throttle just ever so slightly after starting ti keep it smooth. Swapped the thermostat and the IAC. Now I am getting the opposite. Started hard a couple times cold with the new IAC. Just have to juice it a bit and it runs fine. Does the engine need time to recal itself? I know when i did my wifes yota and replaced the air intake and throttle body gaskets it needed some tine to recal itself and reset the check engine light before it ran smooth. The old IAC was full of carbon and was the original with 1130 hrs. In any event I haven't had a hot start issue since the swap and the fuel smell in the exhaust seems to be much less.

JimN
09-09-2013, 04:24 AM
Well I felt was running a little rich lately and was having a small hot start issue on 100 degree days after turning of the engine while swapping riders in the. it would start up but i would have to kick up the throttle just ever so slightly after starting ti keep it smooth. Swapped the thermostat and the IAC. Now I am getting the opposite. Started hard a couple times cold with the new IAC. Just have to juice it a bit and it runs fine. Does the engine need time to recal itself? I know when i did my wifes yota and replaced the air intake and throttle body gaskets it needed some tine to recal itself and reset the check engine light before it ran smooth. The old IAC was full of carbon and was the original with 1130 hrs. In any event I haven't had a hot start issue since the swap and the fuel smell in the exhaust seems to be much less.

The ECM can't do its own recal but the IAC will usually "re-park" itself. On occasion, it won't open to the correct number of steps, though.

How many times have you read about ECT being out of range and causing hot start problems?