PDA

View Full Version : Bayliner won't start


jimmye39
09-03-2013, 09:33 PM
i have a bayliner capri 1950 i don't know anything about it. it was given to me by my boss. it has been sitting for a long time now with all fluid in it and battery connected earlier today i mtook the starter of to repair, when i put it back on the boat didn't crank start or do anything.( idk if it work before he gave it to me ) For the one battery is completely died but i have a special jumper boxs that give is power to start it once, even with that the boat doesn't do anything the panel lights , the throttle doesn't even move. what is wrong with it

Engine is a meCruiser Alpha one 3.0Liter/ LX
Digital Electronic ignition system

j.mccreight@hotmail.com
09-03-2013, 09:45 PM
Welcome to the mastercraft tt forum. Your specific issue might have issues getting resolved on this forum as our boats are mostly v8 fords and v8 gm. First get a fully charged battery on it then start your troubleshooting. Lights, dash should work independent of the engine, so if you got nothing maybe start looking at battery cables, fuses, circuit breakers etc. other than that I got nothing.

http://www.baylinerownersclub.org/forum/forum.php

thatsmrmastercraft
09-03-2013, 11:32 PM
I would try to turn the engine over by hand first. Us a 1/2" drive ratchet or breaker bar on the crankshaft pulley. If the engine is seized up, you have bigger problems.

Corrosion at connections is probably your next battle. Remove and clean all battery and starter cables. Use a wire brush to clean the posts and ring ends and a battery brush to clean inside the battery terminals.

You may have to remove fuses and clean connections there as well.

Good luck.