PDA

View Full Version : Perfect Pass 2003 Maristar 210


CC2MC
08-27-2013, 04:46 PM
After driving the boat for a couple of weekends, I have decided to remove the PP from my old boat and put it into my new one. It is just the 6.5ng, which uses the paddle wheel, but I wanted to see if anyone has done the installation on their boat using the wiring harness supplied by PP that directly hooks into a plug somewhere behind the dash. I wanted to see if anyone knew exactly where it was as it is supposed to pull the paddle wheel info and power in the same cable. I also noted that my old servo cable is only 13' long, which is fine for a direct drive, but I am just not sure that I will have the length needed for a v-drive. I contacted PP about this and they said they offer a 23' cable for v-drive boats but that there is a chance that the shorter cable will work as well. Has anyone else experienced this issue? I did go ahead and order the longer cable just in case, as I can always send it back. I am assuming that there is a tube running from the helm to the bilge for the wires to run through. If anyone knows the answer to that one too, I would be interested to know. I have a couple of hatches I can open to get access, but I just don't know how hard running the cable will be just yet.

I also went ahead and ordered a new gauge, just bc they want $65 plus whatever it costs for me to ship it up there to change the face color and bezel. I would rather just put the $65+ into a new gauge. (I will be putting the old black faced multiline gauge in the classifieds after I get the install done.)

CC2MC
08-28-2013, 05:17 PM
I have searched the threads for info on exactly how to undo the dash. From what I can tell, there are a couple of nuts around the steering column, but I am not sure if that is all that holds it in place. I saw the X1 has a few rivets somewhere and maybe the 210 VRS is the same but I just don't know for sure. I do not have the boat in front of me now and will be attempting all of this on Friday evening. Any help or pics are greatly appreciated.

bigmac
08-28-2013, 07:15 PM
I installed PP on my 2004 230VRS. I don't know how much but I've gt a lot of extra cable coiled up under there.

The factory plug is behind the right side kick panel. It's accessible from under the right bow bench. On mine, I had to make sure that the red wire for PP wasn't connected or PP would get a double signal. That red wire corresponds to the brown wire on the plug harness under the seat. Mine was disconnected (pulled out of the connector block) from the factory but iirc it was left in on the 2003s. My guess is that you need to pull the pin connected to the brown wire on the connector block under your right bow seat.

As to the gauge...afaik you just have to snake your hand under there from underneath. It is a MAJOR pain in the ***.

CC2MC
08-28-2013, 10:11 PM
Thanks bigmac. That does help. I would have been pretty upset if I was getting the double signal and not knowing it. That is key information. I really appreciate that. I do hate to hear that about accessing the gauge. I was hoping that would be the easy part of the job. Aint nothin' easy.