PDA

View Full Version : MC Cruise Help


Coffeyman76
08-19-2013, 10:08 AM
Hey guys I have MC Cruise on my 2006 x45. Been trying for weeks to get it to work with no luck.

When I flip it on in MPH mode it will show the speed I am at (or 0.0 Neutral). I try to adjust the speed and it just flashes LOCK and will not adjust. RPM is the same way.

I have another MC Cruise owner on the boat and he had no idea, his doesn't say that. He just goes to Neutral, sets the speed then hits the throttle and it works perfectly.

Any ideas? I can't even really find good literature on it although admittedly I am swamped and haven't searched the forum like I should probably.

Any help appreciated! Thanks.

mccobmd
08-19-2013, 10:14 PM
I find it works best when you turn the key on with it in the RPM mode and it should flash pull then set a number or RPM. On my x1 with the RTP engine 3000 RPM is about 29 miles per hour. when you start it and speed up it will flash lock until the throttle gets past your rpm setting. I have more luck leaving it in the manual mode. when you take off push the "on" and it will show an RPM, push the throttle forward and the adjust with the plus and minus, if you push quickly it is 20 rpm, hold it longer 100 RPM. It works most of the time if you set it before. I have not had much luck with MPH.

Skyskiguy
08-20-2013, 12:26 AM
Do a search on here and you will find plenty of info on MC Cruise. Some people never have any trouble with it and it works well. I never could get mine to work correctly (2006 X30 bought used in 2012). I believe that the problem lies in the speed control logic in the ECM which is written by Indmar - you'd think that with all the problems people have with it that they would be able to come up with a flash to correct the flaw in the ECM, but that has not been the case. If you have MC Cruise and it works, congratulations. If it doesn't work, call the folks at Perfect Pass and they can help you out. I ended up installing PP StarGazer and couldn't be happier.