PDA

View Full Version : Getting ready to start a rebuilt LT1


hig
08-02-2013, 09:10 PM
I cranked over my motor a few times for the first time tonight to make sure everything sounded okay and it does!!! I had the coils unhooked so it didn't fire up.

The thing I'm wondering, when I first turned the key on I did not hear the fuel pump prime up like a car would, is this normal or is something wrong with the pump or wiring?

Thanks, Steve

gsxrjtt
08-02-2013, 09:18 PM
where are you tar down and rebuild pics .. Im doing a rebuild lt1 now

hig
08-02-2013, 09:38 PM
where are you tar down and rebuild pics .. Im doing a rebuild lt1 now

I have a few pics I took of the motor but most of my pics are of the accessories and wiring, another member took a bunch of pics for me showing how to reassemble the wiring/accessories because the motor was out of the boat when I bought it.

I did purchase this book (http://www.amazon.com/Rebuild-Small-Block-Chevy-Engines-Hp1393/dp/1557883939)on Ebay and it was very helpful with pics and torque specs.

If you have any specific question or pics you need just let me know.

http://i871.photobucket.com/albums/ab280/hig69/98%20Mastercraft/20130519_192952_zps0962f62d.jpg (http://s871.photobucket.com/user/hig69/media/98%20Mastercraft/20130519_192952_zps0962f62d.jpg.html)


http://i871.photobucket.com/albums/ab280/hig69/98%20Mastercraft/20130519_193657_zps29ab6a38.jpg (http://s871.photobucket.com/user/hig69/media/98%20Mastercraft/20130519_193657_zps29ab6a38.jpg.html)
http://i871.photobucket.com/albums/ab280/hig69/98%20Mastercraft/20130717_204713_zps152d8cc6.jpg (http://s871.photobucket.com/user/hig69/media/98%20Mastercraft/20130717_204713_zps152d8cc6.jpg.html)

http://i871.photobucket.com/albums/ab280/hig69/98%20Mastercraft/20130727_100848_zpsc0eae62f.jpg (http://s871.photobucket.com/user/hig69/media/98%20Mastercraft/20130727_100848_zpsc0eae62f.jpg.html)

http://i871.photobucket.com/albums/ab280/hig69/98%20Mastercraft/20130727_100928_zps0735653e.jpg (http://s871.photobucket.com/user/hig69/media/98%20Mastercraft/20130727_100928_zps0735653e.jpg.html)

Steve

hig
08-02-2013, 09:45 PM
where are you tar down and rebuild pics .. Im doing a rebuild lt1 now

That's funny, I subscribed to your thread earlier today to watch your progress. At the bottom of my post is my progress thread if you want to check it out. At the start of my thread I listed a couple of useful threads I found with motor pics in that would help you.

I guess you will be needing reference pics also, unfortunately my boat is a V drive and yours is DD but some of my pics can help.

Steve

Table Rocker
08-02-2013, 10:01 PM
I hear my pump prime when the key is turned to "run."

hig
08-03-2013, 09:39 PM
I hear my pump prime when the key is turned to "run."

Thanks, after a few hours of tracing wires and trying to understand how the fuel pump works I found out the pump was froze up. I ended up jumping the relay and the pump started spinning after a few tries. I hooked the garden hose to it and ran the engine for a few seconds, it ran rough but sounded good and had good oil pressure!!

What should the fuel pressure be at the Schrader valve, I'd like to test it make sure the pump is getting it up to pressure?

Thanks, Steve

1redTA
08-03-2013, 10:00 PM
I think the fuel pressure should be 43-47 with the vacuum gauge unhooked (car)