PDA

View Full Version : very sqeaky belts


Jaxon4
07-29-2013, 12:34 PM
I have a high pitched sqeak coming from engine compartment...i think it's the belt?? Can i just tighten the belt or should it be replaced....Is it easy to tighten the belts??

jafo9
07-29-2013, 04:02 PM
it depends on your motor. my LTR has a tensioner pulley so there is no adjustment. i'm not sure what your motor is, some you adjust the alternator to tighten the belt and others have a dedicated pulley with an adjustment bolt. take a look at the belt, if it looks worn or you see any cracks, go ahead and replace it. keep the old one as a spare for emergencies. old rule of thumb is 1/4 inch or so deflection in the belt on the longest run between pullies.

thatsmrmastercraft
07-29-2013, 04:08 PM
Squeaky belts never get quiet until they break........replace it.

ricford
07-29-2013, 07:09 PM
Pretty cheap insurance to replace it. If you don't you'll be sorry one day, and that will be a day when you have a bunch of friends and family that want to use it, or the first day of your vacation. It never fails at a convenient time.

AZDave
07-29-2013, 07:58 PM
If the belt in not worn and everything with the pulley/tensioner check out, try belt dressing.

sp00ky
07-29-2013, 11:15 PM
If the belt in not worn and everything with the pulley/tensioner check out, try belt dressing.

I wouldn't use belt dressing as it will erode the belt even more.
is your water pump leaking water and getting the pulleys wet?

Jaxon4
07-31-2013, 03:47 PM
thanks ya'll....I figured it out...sheared altenator bolt. Just had to replace bolt and readjust the alt! All good now!

catamount
08-01-2013, 08:42 AM
Hmm, the alternator bolt in my '87 Prostar sheared earlier this year with the same result... a REALLY squeaky belt. Hopefully enough of the stud was left on yours to make it easy to extract. I'm kinda surprised these grade 5 bolts snap in half like that at the alternator mount.

Jaxon4
08-01-2013, 01:23 PM
ya I know...now I have a weird kinda rattle coming from the water pump I think from running it with a loose belt before I realized the bolt was sheared. I think its the water pump!?