PDA

View Full Version : Installed rebuilt trans and problems BW Velvet Drive 1:1


sam196370
07-13-2013, 12:42 PM
Rebuilt the trans myself with very helpful instructions on TT....got it in and started boat, trans turned forward at idle but also when in neutral/reverse and shift lever had no effect. I ran boat for 5 mins and got it up to operating temp but no change.

Do I need to run it longer to get fluid flowing?

Thanks

sam196370
07-13-2013, 04:35 PM
About to take trans out and make sure I have the direction correct, although I've installed a trans with the incorrect direction I forgot the symptoms....anyone know what happens when the direction is wrong? Would hate to go through the trouble of taking it out only to find that I have the pump cover correctly aligned. Bueller?

mikeg205
07-13-2013, 04:38 PM
You'll probably get an answer a bit later... some of the answers come slower in the summer months.

CantRepeat
07-13-2013, 07:45 PM
Rebuilt the trans myself with very helpful instructions on TT....got it in and started boat, trans turned forward at idle but also when in neutral/reverse and shift lever had no effect. I ran boat for 5 mins and got it up to operating temp but no change.

Do I need to run it longer to get fluid flowing?

Thanks

Did you mark the pump and be sure to install it in the same position as it was when you tore it down? Check the shift cam/drum is it installed correctly? Did you check the spacing on the main clutch pack for the correct clearance when you assembled it?

sam196370
07-14-2013, 11:07 AM
Thanks and yes except for shift cam drum.....That's the cylinder that the shift lever is attached to on one side and NSS is on other side I assume? How do I check that? Seems that it can only be installed one way....

André
07-14-2013, 11:22 AM
Does that small cylinder part have a hole in it...
I remember Vince at Skidim explaining to me that it was important to reinstall the same way it came out otherwise something like this would happen...
Did you check in the rebuilding transmission thread here...
Give me a second and will try to find it for you.

Edit:Look in this thread.
http://www.mastercraft.com/teamtalk/showthread.php?t=53874

Edit2 :Part 39 :confused:

sam196370
07-14-2013, 11:56 AM
Thats the thread I used to rebuild trans, I'll double check cylinder.

Thanks