PDA

View Full Version : raw water pump exchange 02 LTR


jafo9
07-06-2013, 04:34 PM
so i noticed for the first time today that i seem to be leaking some water out of the back of the raw water pump. i researched the issue and it seems this is not uncommon. i went ahead and ordered a new pump from skidim. i saw the thread with the break down instructions and replacement seal. i figured after 11 years of service the bearings and shaft likely have seen their better days. even though i have a press, i don't want to have to deal with total rebuild during my off time this summer.

having said that:

1. is swapping the pump out a job that can be done on the water? i'm assuming just make sure the raw water intake hose is elevated above the water line while disconnected and get it connected to the new one asap? i saw the bilge run today so i know it works. i don't mind getting them to put it on a rack at the local marina but it would be less hassle if i could do it at my dock.

2. is the seal which has a slow leak something that will fail quickly or can i still use the boat while i'm waiting on the parts. my thoughts would be to check the leak frequently. my biggest concern would be a catastrophic failure which could stranded me from home. (temp gauge works fine)

Engine Nut
07-07-2013, 09:21 AM
You can replace the pump with the boat in the water. Doesn't your boat have a sea **** near the water pickup in the hull? Otherwise, keeping the water inlet hose above the water level will prevent water from entering the boat.

You can use the boat till the new pump comes unless water is gushing out of the back of the pump. Too bad you already ordered a pump. That same pump is $40.00 less from inboadonline.com.

jafo9
07-07-2013, 10:41 AM
thanks for the reply. next time i need parts, i'll look at inboardonline.

jafo9
07-18-2013, 01:10 PM
so i tried to swap out the pump today. how the heck do you get that thing off. i see the 3 hex head bolts and the bolt on the bracket. i tried every size hex head socket i had and none of them fit. it feels like it should be 3/8 but it just wouldn't fit in the socket. 5/16 was way too small as was 8mm. 10mm is a hair bigger than the 3/8 and it clearly was too big.

any suggestions on the proper way to get those bolts out?