PDA

View Full Version : 1988 Prostar stalling intermittently


tessntatum
07-05-2013, 02:00 PM
I have a 1988 prostar 190 with a 351 indmar with a electronic ignition and a fairly new carburtor. The mechanic thought it might be bad gas. I have worked through the tank and now has fresh gas. When it stalled today I checked the jets to see if they were squirting gas and they were. I sprayed ether in the carb and it still did not start then did after cranking for a while. That leads me to believe it is not fuel. I am thinking electrical any ideas?? Does ford have a power pack for the ignition? Once you get it started again it runs for quite a while. There is no ryme or reason as to when it stalls.
Thanks for the help!!

SSMoose
07-05-2013, 02:27 PM
First check all your ground wires. This sounds like electric to me. Are you getting spark? Otherwise it would seem that it would fire off using ether.

catamount
07-05-2013, 05:31 PM
Agreed, the first thing you need to check for is spark. If you feel the coil when it stalls, is it hot? Does it die quickly, or does it sputter out? Does it ever backfire as you are trying to restart?

Last question: where in the Northeast?

tessntatum
07-08-2013, 02:06 PM
ok so I got a spark tester and there is spark when it stalls. I tried the ether again and it fired right over. Now I am thinking the pickup tube is clogged. How do you remove it? I am thinking the screen is clogged. I blew in the vent tube and it was fine.

catamount
07-08-2013, 02:58 PM
To clean the pickup you simply need to pull the tank and unscrew the pickup. Before I did that, though, I would probably do some more diagnostics. You said that when it dies, is is squirting fuel when you pump the throttle? If it is, then your bowls aren't empty and cleaning the pickup will be a wasted exercise.

Is it stalling at idle or at WOT? Have you tried turning your idle up? Maybe your idle circuit is dirty? Plugs fouled? Etc?

tessntatum
07-08-2013, 04:58 PM
Yesterday it stalled when I started it in the am while I was getting ready to ski so it ran for approx a minute then stalled from idle. Today it stalled while I was pulling a skier. It would only start if you cranked it and kept pumping the gas. It was acting like it was out of gas -sputtering then dying.
Thanks for the help

tessntatum
07-15-2013, 07:00 PM
pulled the boat and removed the tank-emptied and cleaned it. Replaced the pickup tube that was rotted at the bottom. Removed and replaced all the fuel lines(in bad shape) and filters. It has run fine since.