PDA

View Full Version : Problems Getting New Longblock running


svxwilson
06-19-2013, 06:42 PM
Ok I have got the new longblock installed and my mechanic is having issues getting it to run. He originally ran with the factory firing order and it would not run. He tried a couple other firing orders that all did not work. He did a pop test and used the order from that and got it to run but only on 4-6 pistons. It would idle but very ruff.
My mechanic has done many boat engine swaps but never a reverse rotation such as this. He is aware and has educated himself in the reverse rotation motor and what makes it different.
He has a different carb he is going to put on it that he knows is good to test and see if that isn't needing a rebuild. Being a dumb *** when I took the intake off I decided to "inspect the carb" by inverting it over my head, and proceeded to take a gasoline bath.
Longblock should be good. Has a 7 year warranty. He did have to loosen the nuts on the valve springs because when it was at top dead center some were still tight.
Piston 1, and 8 are definitely working on almost all the firing orders.
2-4 of the pistons are doing nothing in all the different firing orders.

Any other ideas???

Table Rocker
06-19-2013, 07:10 PM
Weren't Ski Brendellas standard rotation? Does your prop say RC or LC? The prop charts I have Googled show Brendalla as standard rotation.

(I know absolutely nothing about Ski Brendella boats)

silverblueBP
06-19-2013, 07:11 PM
Have you pulled the valve covers and hand rotated the engine, following the firing order of each cylinder? You get that and then set # 1 at TDC on the compression stroke. Note where the rotor is pointed and attach the plug wires to the cap. It's not that complicated when you break it down into each part.

petermegan
06-19-2013, 07:39 PM
Out of my league here but the raw water pump would be a give away for engine rotation and if following the firing order by watching the valves rock at TDC is too hard, I wonder whether putting plastic plugs in your spark plug holes and rotating the engine would be easier?? Has your 'mechanic' taken the rocker covers off, or is he just guessing? Have fun.

svxwilson
06-20-2013, 03:41 AM
Engine builders gave us the wrong firing order. Did a pop test to find the correct firing order. Used that order and it ran great. Taking it to the lake Thursday.

thatsmrmastercraft
06-20-2013, 07:46 AM
Perhaps an end to your struggles. Good luck on the water.