PDA

View Full Version : help!


agarabaghi
06-12-2013, 04:14 PM
Ran out of fuel. My bad.
Put fuel in boat wouldnt start.
Pulled fuel pump out tested pump on 12v and a cup of gas and it worked.
Put everything back together boat ran fine for a day
Filled up today and boat is studdering and sputtering like crazy in idle. runs fine wot.
Pull into dock turn off boat and engine is still kinda running sputtering and eventually stalls out....

??/

André
06-12-2013, 04:15 PM
You could have clogged the fuel pump screen at the inlet with debris.
No cost to checking that first.
Good luck!

agarabaghi
06-12-2013, 04:17 PM
pump come and go? i figured if it was dead it was dead... not that it would kinda work..?

D3skier
06-12-2013, 04:18 PM
fuel filter?

agarabaghi
06-12-2013, 04:20 PM
i didnt replace it because i replaced it fairly recently (last time i killed a fuel pump)... how exactly would a fuel filter affect the engine from running? It looks yellow and clean... bottom of tank was really clean too...

D3skier
06-12-2013, 04:34 PM
i didnt replace it because i replaced it fairly recently (last time i killed a fuel pump)... how exactly would a fuel filter affect the engine from running? It looks yellow and clean... bottom of tank was really clean too...

possibly something floating around inside that could block off the line but just an idea here... very possible the pump cutting in and out

CantRepeat
06-12-2013, 04:39 PM
Go to napa and get a $20 fuel pressure test gauge and test your pressure.

snork
06-12-2013, 05:10 PM
sounds like the pump, also check the elec connection to the pump by unplugging and replugging a couple of times, I've witnessed that work a few times